Bug 12444 - WCF WebService - Generating incorrectly.
Summary: WCF WebService - Generating incorrectly.
Status: NEW
Alias: None
Product: Class Libraries
Classification: Mono
Component: WCF assemblies (show other bugs)
Version: unspecified
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-05-28 21:52 UTC by Ruda
Modified: 2013-09-03 05:06 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Xamarin Studio (13.41 KB, application/octet-stream)
2013-05-28 21:52 UTC, Ruda
Details
Visual Studio (9.97 KB, application/octet-stream)
2013-05-28 21:53 UTC, Ruda
Details
Xamarin Studio - Version (909 bytes, text/plain)
2013-05-28 21:53 UTC, Ruda
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 12444 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEW

Description Ruda 2013-05-28 21:52:24 UTC
Created attachment 4034 [details]
Xamarin Studio

Generator WebService has a problem.
When to generate a WebService. WCF net. It generates incorrectly.
First the namespace was not placed in the correct place.
Getting some classes without namespace.

Another problem is that the namespace of the interface is incorrect. He is putting the project's namespace and not the namespace of the webservice.

I put here the Reference.cs Xamarin Studio and Visual Studio the same WebService.

[System.ServiceModel.ServiceContractAttribute (Namespace = "The problem is here")]

And these errors make the Webservice does not work, and I'll update whenever correct.
Comment 1 Ruda 2013-05-28 21:53:11 UTC
Created attachment 4035 [details]
Visual Studio
Comment 2 Ruda 2013-05-28 21:53:32 UTC
Created attachment 4036 [details]
Xamarin Studio - Version