Bug 12401 - GL.DeleteTexture is missing uint overload
Summary: GL.DeleteTexture is missing uint overload
Status: VERIFIED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: Xamarin.iOS.dll (show other bugs)
Version: 6.2.x
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: Untriaged
Assignee: Rolf Bjarne Kvinge [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2013-05-27 05:48 UTC by Jonas Sourlier
Modified: 2013-06-17 07:40 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Jonas Sourlier 2013-05-27 05:48:06 UTC
The method

GL.DeleteTexture(int textureId)

accepts only an int-typed texture ID. However, other OpenGL ES methods like BindTexture operate with uint IDs exclusively. Other methods like GenTextures accept both uint and int values.

See also http://www.opentk.com/node/1960
Comment 1 Rolf Bjarne Kvinge [MSFT] 2013-05-31 06:42:02 UTC
It looks like this is an upstream bug:

http://opentk.svn.sourceforge.net/viewvc/opentk/trunk/Source/OpenTK/Graphics/ES20/Helper.cs?revision=3117&view=markup

Only the int overload is present in that file.

I filed an upstream bug about this: http://www.opentk.com/node/3333
Comment 2 Rolf Bjarne Kvinge [MSFT] 2013-05-31 06:56:54 UTC
In any case I went ahead and fix this in our opentk clone.

opentk: bea28e54e19ec625f3a272e3db935d292c63874a
monotouch: a52ff4ad706ecda8eb87ee2271507d68979c0e60
Comment 3 narayanp 2013-06-17 07:36:34 UTC
To verify this issue we have opened GLPaint-GameView application and tried to add code "GL.DeleteTexture (uint TextureUnit ) and GL.Deletetexture (int TextureUnit)" and we are successfully able to use 'uint'. This is the screencast for the same: http://screencast.com/t/6uAnCLUWUvYE

X.S 4.0.7-1
Xamarin.iOS 6.3.6-76
Mono 3.0.11

Changing the status to Verified.
Comment 4 Jonas Sourlier 2013-06-17 07:40:48 UTC
:D the way you're 'verifying' it, you could also pass string variables or elephants to OpenGL..