Bug 12059 - UITextField.InputDelegate un-settable, assigning the property with valid instance results in property staying null
Summary: UITextField.InputDelegate un-settable, assigning the property with valid inst...
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: iOS
Classification: Xamarin
Component: XI runtime (show other bugs)
Version: 6.2.x
Hardware: PC Mac OS
: --- normal
Target Milestone: Future Cycle (TBD)
Assignee: Sebastien Pouliot
URL:
Depends on:
Blocks:
 
Reported: 2013-05-01 14:13 UTC by kenny goers
Modified: 2017-10-06 12:35 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description kenny goers 2013-05-01 14:13:52 UTC
I'm trying to use the InputDelegate on UITextField, when I assign the InputDelegate property, it stays null even after assignment is complete.

As an explanation, I need to unbind the delegate thus the reason for using the delegate object instead of the events.
Comment 1 Sebastien Pouliot 2013-05-01 14:58:43 UTC
Looks broken, looking into it...
Comment 3 PJ 2013-11-19 16:44:37 UTC
This bug was targeted for a past milestone, moving to the next non-hotfix active milestone.
Comment 4 GouriKumari 2016-01-11 21:28:47 UTC
Moving this bug to "far future".
Comment 5 Rolf Bjarne Kvinge [MSFT] 2017-10-06 12:35:19 UTC
This seems to work fine with this test code: https://gist.github.com/rolfbjarne/c74db61dd4601c873ab787e0acf10702

If this is still an issue, please attach a complete test project and reopen the bug.