Bug 11100 - xsp segfaults on mono 3.0.8 (March 13)
Summary: xsp segfaults on mono 3.0.8 (March 13)
Status: NEEDINFO
Alias: None
Product: Runtime
Classification: Mono
Component: JIT (show other bugs)
Version: unspecified
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-03-13 04:11 UTC by Artyom Antyipin
Modified: 2017-10-14 00:09 UTC (History)
3 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
crash stack trace (12.90 KB, text/plain)
2013-03-13 04:11 UTC, Artyom Antyipin
Details

Description Artyom Antyipin 2013-03-13 04:11:28 UTC
Created attachment 3592 [details]
crash stack trace

mono trunk:
Mono JIT compiler version 3.0.8 (master/988f522 2013. march. 13., 08.15.57 CET)
Copyright (C) 2002-2012 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
	TLS:           __thread
	SIGSEGV:       altstack
	Notifications: epoll
	Architecture:  amd64
	Disabled:      none
	Misc:          softdebug 
	LLVM:          yes(3.2svn-mono)
	GC:            Included Boehm (with typed GC and Parallel Mark)

fastcgi_mono_server4 crashes on first access with segfault (traces attached)

Stack trace provided for sgen version, but the same happens when using Boehm GC..
Comment 1 Rodrigo Kumpera 2017-10-14 00:09:29 UTC
Thank you for your report!

It appears you are running a very old version of Mono. Could you please try to update to any recent version and try to reproduce the issue again.

If the issue still persists please include the version information and change the bug status to NEW.

Note You need to log in before you can comment on or make changes to this bug.