Bug 976

Summary: Closing the Deploy to Device pad with the red icon to the right causes a NREX
Product: [Desktop] Xamarin Studio Reporter: Marek Habersack <grendel>
Component: Android Add-inAssignee: shana <shana>
Status: RESOLVED NORESPONSE    
Severity: normal CC: alan, miguel, mono-bugs+monodevelop
Priority: ---    
Version: 2.6   
Target Milestone: ---   
Hardware: PC   
OS: Windows   
Tags: Is this bug a regression?: ---
Last known good build:

Description Marek Habersack 2011-09-21 19:20:33 UTC
MonoDevelop installed on Windows 7 inside a VirtualBox VM, MonoForAndroid 1.2.0, a real device connected to the VM. Deployment doesn't work (due to VirtualBox's USB support being flaky) so I tried to abort the deployment which resulted in the following crash:

ERROR [2011-09-22 00:47:45Z]: Unhandled Exception
System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.Runtime.Remoting.RemotingException: Remoting cannot find field 'outputMonitors' on type 'MonoDevelop.Ide.Gui.ProgressMonitorManager'.

Server stack trace: 
   at System.Object.GetFieldInfo(String typeName, String fieldName)
   at System.Object.FieldGetter(String typeName, String fieldName, Object& val)
   at System.Runtime.Remoting.Messaging.Message.Dispatch(Object target, Boolean fExecuteInContext)
   at System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage msg, Int32 methodPtr, Boolean fExecuteInContext)

Exception rethrown at [0]: 
   at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
   at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
   at System.Object.FieldGetter(String typeName, String fieldName, Object& val)
   at MonoDevelop.Ide.Gui.ProgressMonitorManager.<>c__DisplayClass3.<CreateMonitorPad>b__1(Object , EventArgs )
   at System.EventHandler.Invoke(Object sender, EventArgs e)
   at MonoDevelop.Ide.Gui.PadWindow.NotifyHidden()
   at MonoDevelop.Ide.Gui.DefaultWorkbench.<>c__DisplayClasse.<AddPad>b__b(Object , EventArgs )
   at MonoDevelop.Components.Docking.DockItem.UpdateVisibleStatus()
   at MonoDevelop.Components.Docking.DockItem.set_Visible(Boolean value)
   at MonoDevelop.Components.Docking.DockItemContainer.<>c__DisplayClass4.<.ctor>b__0(Object , EventArgs )
   --- End of inner exception stack trace ---
   at System.RuntimeMethodHandle._InvokeMethodFast(IRuntimeMethodInfo method, Object target, Object[] arguments, SignatureStruct& sig, MethodAttributes methodAttributes, RuntimeType typeOwner)
   at System.RuntimeMethodHandle.InvokeMethodFast(IRuntimeMethodInfo method, Object target, Object[] arguments, Signature sig, MethodAttributes methodAttributes, RuntimeType typeOwner)
   at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture, Boolean skipVisibilityChecks)
   at System.Delegate.DynamicInvokeImpl(Object[] args)
   at GLib.Signal.ClosureInvokedCB(Object o, ClosureInvokedArgs args)
   at GLib.SignalClosure.Invoke(ClosureInvokedArgs args)
   at GLib.SignalClosure.MarshalCallback(IntPtr raw_closure, IntPtr return_val, UInt32 n_param_vals, IntPtr param_values, IntPtr invocation_hint, IntPtr marshal_data)
ERROR [2011-09-22 00:48:54Z]: Error in async operation chain
System.NullReferenceException: Object reference not set to an instance of an object.
   at MonoDevelop.MonoDroid.MonoDroidUploadOperation.<>c__DisplayClass2a.<.ctor>b__10(AdbShellOperation op)
   at MonoDevelop.MonoDroid.ChainedAsyncOperation`1.<.ctor>b__1(IAsyncOperation op)
   at MonoDevelop.MonoDroid.ChainedAsyncOperationSequence.OpCompleted(IAsyncOperation op)
Comment 1 Alan McGovern 2011-09-30 13:16:04 UTC
This appears to be fixed as I can't repro it. Marek, if you can't repro this with MD 2.8 b3 (or master), could you close this bug?
Comment 2 PJ 2013-11-19 17:04:30 UTC
This bug has been in the NEEDINFO state with no changes for the last 90 days. Can we put this back into the NEW or CONFIRMED state, or are we still awaiting response?

If there is no change in the status of this bug over the next two weeks, this bug will be marked as NORESPONSE.
Comment 3 PJ 2013-12-05 18:34:35 UTC
This bug has not been changed from the NEEDINFO state since my previous comment, marking as RESOLVED NORESPONSE.

Please feel free to REOPEN this bug at any time if you are still experiencing the issue. Please add the requested information and set the bug back to the NEW (or CONFIRMED) state.