Bug 8927

Summary: CodeDom doesn't handle snippets correctly, breaks Razor
Product: [Mono] Class Libraries Reporter: Mikayla Hutchinson [MSFT] <mhutch>
Component: SystemAssignee: Bugzilla <bugzilla>
Status: RESOLVED FIXED    
Severity: normal CC: masafa, mono-bugs+mono
Priority: ---    
Version: master   
Target Milestone: Untriaged   
Hardware: PC   
OS: Mac OS   
Tags: Is this bug a regression?: ---
Last known good build:
Attachments: Demonstrates broken code generation on Mono.

Description Mikayla Hutchinson [MSFT] 2012-12-13 18:28:52 UTC
Created attachment 3094 [details]
Demonstrates broken code generation on Mono.

The C# CodeDOM provider does not ensure that a CodeSnippetTypeMember and a CodeMemberMethod are separated when CodeGeneratorOptions.BlankLinesBetweenMembers=false.

This breaks Razor because it generates this exact pattern.

The attached sample demonstrates this. It works on .NET but generates broken code on Mono.
Comment 1 Marek Safar 2012-12-15 06:48:20 UTC
Fixed in master