Bug 8557

Summary: Default value for TaskScheduler.MaximumConcurrencyLevel different between MS.NET and Mono
Product: [Mono] Class Libraries Reporter: Karol Gwaj <karol.gwaj>
Component: mscorlibAssignee: Bugzilla <bugzilla>
Status: RESOLVED FIXED    
Severity: normal CC: masafa, mono-bugs+mono
Priority: ---    
Version: 2.10.x   
Target Milestone: Untriaged   
Hardware: PC   
OS: Linux   
Tags: Is this bug a regression?: ---
Last known good build:

Description Karol Gwaj 2012-11-22 10:54:47 UTC
Looks like default value for TaskScheduler.MaximumConcurrencyLevel is different between MS.NET and Mono:
MONO: TaskScheduler.MaximumConcurrencyLevel == <processors count>
MS.NET: TaskScheduler.MaximumConcurrencyLevel == int.MaxValue

it is making difference, because Mono methods on Parallel class (ForEach, Invoke, ...) in some cases execute much slower than in MS.NET (if you specify parallelizm level greater than number of processors)
Comment 1 Marek Safar 2012-11-23 06:42:53 UTC
Fixed in master