Bug 56177

Summary: peverify fails on FSharp.Core.dll with mono_os_mutex_lock: pthread_mutex_lock failure
Product: [Mono] Runtime Reporter: Jason Imison <jason.imison>
Component: ToolsAssignee: Rodrigo Kumpera <kumpera>
Status: RESOLVED FIXED    
Severity: normal CC: kumpera, luis.aguilera, mono-bugs+mono, mono-bugs+runtime, v-chimuk
Priority: ---    
Version: 5.0   
Target Milestone: 15.2.2   
Hardware: PC   
OS: Mac OS   
Tags: Is this bug a regression?: ---
Last known good build:
Attachments: FSharp.Core.dll

Description Jason Imison 2017-05-10 13:38:51 UTC
Created attachment 22064 [details]
FSharp.Core.dll

14:33 $ peverify /Users/jason/src/FSharp.Compiler.Service/bin/v4.5/FSharp.Core.dll
mono_os_mutex_lock: pthread_mutex_lock failed with "Invalid argument" (22)
Abort trap: 6
Comment 1 Rodrigo Kumpera 2017-05-16 23:24:02 UTC
PR: https://github.com/mono/mono/pull/4885
Comment 2 Rodrigo Kumpera 2017-05-17 18:16:04 UTC
Fixed
Comment 3 Jason Imison 2017-05-17 18:23:45 UTC
Thanks!
Comment 4 Chiranjib Mukherjee 2017-05-19 12:25:26 UTC
@ Jason Imison 

Can you please provide more details about the Bug

Thanks
Comment 5 Jason Imison 2017-05-31 19:49:18 UTC
*** Bug 55801 has been marked as a duplicate of this bug. ***
Comment 6 Jason Imison 2017-05-31 19:50:43 UTC
@Chiranjib - just run `peverify` against any dll file from the terminal