Bug 53689

Summary: [Test] Certificate7 disabled due to SecCertificateCreateWithData does different things on 10.11 vs 10.12 with invalid certificates
Product: [Mono] Class Libraries Reporter: Chris Hamons <chris.hamons>
Component: mscorlibAssignee: Martin Baulig <martin.baulig>
Status: CONFIRMED ---    
Severity: normal CC: andi.mcclure, mono-bugs+mono
Priority: ---    
Version: master   
Target Milestone: Untriaged   
Hardware: PC   
OS: Mac OS   
Tags: Is this bug a regression?: ---
Last known good build:

Description Chris Hamons 2017-03-22 01:57:35 UTC
https://github.com/mono/mono/pull/4470 ran across this gem:

SecCertificateCreateWithData with an invalid certificate returns an actual item on 10.11, but null on 10.12

This makes the test fail, but only on mono bots.

I disabled the test for now.

[MacNotWorking] // SecCertificateCreateWithData does different things on 10.11 vs 10.12 with invalid certificates
public void Certificate7 ()


We should do something better when we're not blocking a merge.
Comment 1 Martin Baulig 2017-03-22 14:32:06 UTC
Interesting!  I have macOS Sierra 10.2.3.

We should investigate whether the SecCertificateRef that's returned on 10.11 has some properties which would identify it as an invalid certificate.

It'd also be interesting to check why exactly the certificate from that test is invalid.

Let's just disable the test for now, I'll have a look at it.
Comment 2 Andi McClure 2017-04-04 21:49:27 UTC
More information about how this expressed itself in tests here https://bugzilla.xamarin.com/show_bug.cgi?id=53958