Bug 53334

Summary: es-US Culture wrong number formatting
Product: [Mono] Class Libraries Reporter: Diego <davrdavr>
Component: SystemAssignee: Marek Safar <masafa>
Status: RESOLVED FIXED    
Severity: normal CC: davrdavr, masafa, mono-bugs+monotouch, mono-bugs+mono, timothy.risi
Priority: ---    
Version: 4.8.0 (C9)   
Target Milestone: Untriaged   
Hardware: Other   
OS: Mac OS   
Tags: Is this bug a regression?: ---
Last known good build:
Attachments: Test project

Description Diego 2017-03-15 00:26:32 UTC
Created attachment 20327 [details]
Test project

Goood day Xamarin team support

In IOS only, using the latest Xamarin Forms stable version, most of culture combinations working fine but "es-US" culture info is wrongly applying formatting over the NumberGroupSeparator, after the first group, next groups is no applied the separator.

For instance: 
value = 123456789

this.NumberUSA = value.ToString("N0", new CultureInfo("es-US"));       // 123456,789
this.NumberUSA = value.ToString("N0", new CultureInfo("en-US"));       // 123,456,789
this.NumberEspana = value.ToString("N0", new CultureInfo("es-ES"));    // 123.456.789
this.NumberColombia = value.ToString("N0", new CultureInfo("es-CO"));  // 123.456.789
this.NumberArgentina = value.ToString("N0", new CultureInfo("es-AR")); // 123.456.789

As we can see, the first "es-US" culture formatting is wrong.
All others are fine.

The attached test app project is used to verify the reported case.
Comment 1 Timothy Risi 2017-03-15 08:14:07 UTC
I can confirm I'm getting the same error, but this looks like it's actually a bug with Mono as opposed to XI itself.  I get the same output if I use the given code sample in a .net console project on mac.
Comment 2 Marek Safar 2017-03-16 09:25:48 UTC
Fixed in master
Comment 3 Diego 2017-03-20 12:50:00 UTC
After one bug is fixed in master, how long it will take to be released in the next stable version. If this fix is in a pre-release version, which one I have to use, or how could I use it?

Thanks in advance.