Bug 53153

Summary: Implement RuntimeHelpers::IsReferenceOrContainsReferences
Product: [Mono] Runtime Reporter: Marek Safar <masafa>
Component: JITAssignee: Bugzilla <bugzilla>
Status: RESOLVED FIXED    
Severity: normal CC: mono-bugs+mono, mono-bugs+runtime, vargaz
Priority: ---    
Version: master   
Target Milestone: ---   
Hardware: PC   
OS: Mac OS   
Tags: Is this bug a regression?: ---
Last known good build:

Description Marek Safar 2017-03-08 13:37:40 UTC
for now it always returns true
Comment 1 Marek Safar 2017-03-09 14:18:31 UTC
CoreFX implementation looks like

        [Intrinsic]
        public static bool IsReferenceOrContainsReferences<T>()
        {
            var pEEType = EETypePtr.EETypePtrOf<T>();
            return !pEEType.IsValueType || pEEType.HasPointers;
        }
Comment 2 Zoltan Varga 2017-03-09 23:08:36 UTC
https://github.com/mono/mono/pull/4500
Comment 3 Zoltan Varga 2017-03-12 04:51:04 UTC
-> FIXED.