Bug 46972

Summary: ListViews not respecting binding when a GRID is used in the data template
Product: Forms Reporter: Stacy Henwood <stacyh>
Component: FormsAssignee: Bugzilla <bugzilla>
Status: VERIFIED FIXED    
Severity: normal CC: adrianknight89, jas, paul.dipietro, v-amdha
Priority: ---    
Version: 2.3.1   
Target Milestone: ---   
Hardware: PC   
OS: Windows   
Tags: Is this bug a regression?: ---
Last known good build:
Attachments: Reproducer
Attached IDE logs

Description Stacy Henwood 2016-11-15 03:48:24 UTC
If you have a GRID in the datatemplate (either in the group header or in the item) then the bindings will not work correctly. If you update a string value, then it does not update in the template, but rather gets set to an empty string.

If you wrap the Grid in a Stacklayout, it magically starts to work again.

I will attach a reproducer project, based on the Xamarin Forms Samples on github.
Comment 1 Stacy Henwood 2016-11-15 03:52:32 UTC
Created attachment 18462 [details]
Reproducer

Modified group list view from github

Uncomment the StackLayout in the .xaml file to see correct behaviour, re-comment to see bug
Comment 2 adrianknight89 2016-11-18 04:34:04 UTC
Which platform is this happening on?
Comment 3 Stacy Henwood 2016-11-20 19:38:09 UTC
Windows 8/8.1 and UWP

In the project (attached to this call) iOS and Android projects are also included, but i have not confirmed that the bug occurs in those environments.
Comment 4 Paul DiPietro [MSFT] 2017-03-24 22:17:31 UTC
This looks to be resolved as of the 2.3.5.73-nightly.
Comment 5 Aman Dharwal 2017-07-13 11:59:15 UTC
Created attachment 23531 [details]
Attached IDE logs

This issue doesn't exist anymore, hence marking it as Verified

=========================================================================

Environment info : https://gist.github.com/saurabh-paunikar/4932c704b6a205cf61457a008c16f8be

Screencast link : https://www.screencast.com/t/8o1Hx6dw0NP