Bug 45060

Summary: Wrong scroll values are passed inside scroll view scrolled event.
Product: Forms Reporter: Dharmendar <dharmendar.dhanasekar>
Component: AndroidAssignee: Bugzilla <bugzilla>
Status: RESOLVED DUPLICATE    
Severity: normal CC: adrianknight89, cnharishkrish, d.weber, david, jas, paul.dipietro
Priority: ---    
Version: 2.3.0   
Target Milestone: ---   
Hardware: PC   
OS: Windows   
Tags: Is this bug a regression?: ---
Last known good build:
Attachments: Wrong scroll values are passed in the scrollview

Description Dharmendar 2016-10-05 14:26:13 UTC
Created attachment 17887 [details]
Wrong scroll values are passed in the scrollview

Hi Team,

Wrong scroll values are passed in the scrollview scrolled event when orientation is set as both.

When looking into  call stack I have found reason behind this issue, when scrolling horizontally, scrollx and scrolly of horizontal scrollview is passed and when scrolling  vertically scrollx and scrolly of vertical scrollview is passed in scrolled events instead of actual scrollx and scrolly value.

Regards,
Dharmendar
Comment 1 adrianknight89 2016-10-11 20:29:14 UTC
I worked on this issue already. See https://github.com/xamarin/Xamarin.Forms/pull/394

You should test when it's merged and update this bug report.
Comment 2 adrianknight89 2016-10-11 20:31:21 UTC
Duplicate of https://bugzilla.xamarin.com/show_bug.cgi?id=41415
Comment 3 Paul DiPietro [MSFT] 2016-10-19 23:32:30 UTC

*** This bug has been marked as a duplicate of bug 41415 ***