Bug 44551

Summary: [Cycle 8] Attempting to deploy app with "iOS Application > Devices" set to "iPhone/iPod" on physical iPad has no effect and produces no error messages or warning in any log files
Product: Visual Studio Extensions Reporter: Brendan Zagaeski (Xamarin Support) <brendan.zagaeski>
Component: iOSAssignee: mag <mag>
Status: VERIFIED FIXED    
Severity: major CC: joe, kzu, mag, mono-bugs+bugzilla
Priority: ---    
Version: 4.2.0 (C8)   
Target Milestone: 4.2.1 (C8SR1)   
Hardware: PC   
OS: Windows   
Tags: BZRC8S1_C7SR1S1 Is this bug a regression?: Yes
Last known good build: Cycle 7 SR 1
Attachments: IDE log files for both default and verbose logging

Description Brendan Zagaeski (Xamarin Support) 2016-09-21 03:21:32 UTC
Created attachment 17627 [details]
IDE log files for both default and verbose logging

[Cycle 8] Attempting to deploy app with "iOS Application > Devices" set to "iPhone/iPod" on physical iPad has no effect and produces no error messages or warning in any log files




## Regression status: Regression in Cycle 8 compared to Cycle 7 SR 1



### BAD: Cycle 8

XamarinVS 4.2.0.680 (c4382f5)

Xamarin.iOS 10.0.0.6 (xcode8: 6c3fee4)
Mono 4.6.0 (mono-4.6.0-branch/746756c)
Xcode 8.0, Build version 8A218a

(Same results with Xcode 7.3, Build version 7D175)



### GOOD: Cycle 7 SR 1

XamarinVS 4.1.2.18 (fcbe082)

Xamarin.iOS 9.8.2.22 (cycle7-sr1: f37444a)
Mono 4.6.0 (mono-4.6.0-branch/746756c)
Xcode 7.3, Build version 7D175



### GOOD: Cycle 6 SR 4

XamarinVS 4.0.4.4 (a9c7826)

Xamarin.iOS 9.6.2.4 (cycle6-xi: d8bedd0)
Mono 4.2.4 (explicit/71b88f3)
Xcode 7.3, Build version 7D175




## Steps to replicate

1. Create a new "Visual C# > iOS > iPad > Single View App (iPhone)".

2. Select "Debug > Start Debugging" to build and run the project on an iPad (tested on iPad Mini 2, iOS 8.0) in the "Debug|iPhone" configuration.




## BAD Results

The only visible result is that the "Output > Debug" window shows something similar to:

> Launching 'UnifiedSingleViewIphone1' on 'iPad Mini 2'...


- None of the default-verbosity log files from "Help > Xamarin > Zip Logs" contain any error messages.


- The verbose logs files from "Help > Xamarin > Zip Logs" don't contain any error messages either.  The only new message I notice is:

> Xamarin.Messaging.Client.Ssh.SshCommandRunner Verbose: 0 : [2016-09-20 23:12:50.2664] Executing SSH command 'ls "/Users/macuser/Library/Caches/Xamarin/mtbs/builds/UnifiedSingleViewIphone1/9c59b12813521598f8c3d0554dc0f47d/obj/iPhone/Debug/build-signature/signature"'...
> Xamarin.Messaging.Client.Ssh.MessagingScpClient Verbose: 0 : [2016-09-20 23:12:50.4852] Downloading 



## GOOD Results (on Cycle 7 SR1)

The app deploys and launches on the iPad even though "iOS Application > Devices" is set to "iPhone/iPod".  I believe this is the expected correct behavior.  (See for example Bug 26545.)




## Additional test environment info (brief)

Microsoft Visual Studio Professional 2015, 14.0.25431.01 Update 3
Windows 10 (Build 10240) 64-bit

OS X 10.11.6

Test device: iPad Mini 2, iOS 8.0
Comment 1 xamarin-release-manager 2016-09-22 19:46:19 UTC
Fixed in version 99.0.0.3609 (master)

Author: Mauro Agnoletti
Commit: 37cd88bff1f6398d60082a44ff1ffb120b5e568f (xamarin/XamarinVS)
Comment 2 xamarin-release-manager 2016-09-22 19:46:39 UTC
Fixed in version 4.2.0.694 (cycle8)

Author: Mauro Agnoletti
Commit: 46c3043eb2e878b1a825c46f23c7ae26864e6125 (xamarin/XamarinVS)
Comment 3 mag@xamarin.com 2016-09-22 19:49:27 UTC
@Brendan,

I wasn't able to reproduce the issue exactly as you reported, given that I wasn't able to launch an iPad application on an iPad device, but at least I got some feedback on the logs.

Based on that, I detected an issue that we had on our IDB agent related to mtouch stderr handling, and I fixed it.

After that, I was able to launch apps on devices.

Please confirm if you still have errors based on the fix commits above.
Comment 4 Brendan Zagaeski (Xamarin Support) 2016-09-22 19:55:37 UTC
Sounds good, thanks!  I'll make a verification attempt once the builds are ready.
Comment 6 mag@xamarin.com 2016-09-23 16:41:50 UTC
Brendan,

The checksum error is caused because of cycle8 has signing enabled now, which impacts in the way we calculate the checksums and verify the integrity of XMA content.

There is a fix and improvement for this in master, and now it's also available on cycle8 from commit 1d46057463b7ac38fe1a4aa52e89555250a38014

You should not get this error anymore.
Comment 7 Brendan Zagaeski (Xamarin Support) 2016-09-28 01:47:16 UTC
## Verification status: unfortunately, not yet fixed by the candidate changes

BAD: XamarinVS 4.2.0.713 (730e8d1)
BAD: XamarinVS 4.2.0.680 (c4382f5)
Comment 11 Brendan Zagaeski (Xamarin Support) 2016-10-14 20:43:03 UTC
## Verification status: by some bad luck, the new candidate changes have not yet resolved this particular issue

BAD: XamarinVS 4.2.0.758 (9535b34) + Xamarin.iOS 10.0.1.8 (3983064)
BAD: XamarinVS 4.2.0.703 (3b7df6f) + Xamarin.iOS 10.0.1.8 (3983064)

(Note I used `copy /B filename +,,` on each of the agent .zip files in `%ProgramFiles(x86)%\Microsoft Visual Studio 14.0\Common7\IDE\Extensions\Xamarin\Xamarin\4.2.0.758` to fix up the timestamps to they would upload successfully to the Mac.)




## Additional test environment info (brief)

Microsoft Visual Studio Professional 2015, 14.0.25431.01 Update 3
Windows 10 (Build 10240) 64-bit

OS X 10.11.6

Xcode 8.0, Build version 8A218a



### Test devices

- iPad Mini 2, iOS 8.0, name contains letters, numbers, and spaces

- iPad Mini 3 (Model A1599), iOS 8.1.3 (12B466), name contains only letters and numbers (no spaces or punctuation)

- iPad Mini 2 (Model A1489), iOS 9.3.2 (13F69), name contains only letters
Comment 12 xamarin-release-manager 2016-10-18 22:37:25 UTC
Fixed in version 4.3.0.102 (master)

Author: josegallardo
Commit: 1a41be9cc8d55f77d80ff6dbc0a3d555316becee (xamarin/XamarinVS)
Comment 13 xamarin-release-manager 2016-10-18 22:37:28 UTC
Fixed in version 4.2.1.21 (cycle8)

Author: josegallardo
Commit: c364d44a1dd2ad2617df855d3ccaccbce800ccef (xamarin/XamarinVS)
Comment 15 Brendan Zagaeski (Xamarin Support) 2016-10-27 23:35:33 UTC
## Verification status: verified fixed in the latest development builds on the cycle8 branch

GOOD: XamarinVS 4.2.1.21 (9c7ac67) + Xamarin.iOS 10.0.2.3 (xcode8: 26328e0)
BAD:  XamarinVS 4.2.1.15 (2ecdcdd) + Xamarin.iOS 10.0.2.3 (xcode8: 26328e0)

(Note: 9c7ac67 is the corresponding merge commit on the cycle8 branch for the commit from Comment 13.)


Thanks!