Bug 43954

Summary: mSYM directory is missing from Android archive
Product: [Desktop] Xamarin Studio Reporter: Kyle White <kyle.white>
Component: Android Add-inAssignee: Greg Munn <gregm>
Status: VERIFIED FIXED    
Severity: normal CC: gregm, mohitk, mono-bugs+monodevelop, prashantm
Priority: ---    
Version: Trunk   
Target Milestone: (C8)   
Hardware: Macintosh   
OS: Mac OS   
Tags: Is this bug a regression?: ---
Last known good build:

Description Kyle White 2016-09-01 21:06:19 UTC
Steps to reproduce:
1) Create an android proejct
2) Archive the project
3) Open the archive in Finder

Expected results: msym directory is present in the archive

Actual result: the msym directory is absent

About info and logs: https://gist.github.com/kdubau/baa153cf0e7e3d2dcb2c4eec20e1f5c2
Comment 1 Kyle White 2016-09-01 21:29:20 UTC
due to https://bugzilla.xamarin.com/show_bug.cgi?id=43551
Comment 2 xamarin-release-manager 2016-09-01 21:44:28 UTC
Fixed in version 6.2.0.434 (master)

Author: Greg Munn
Commit: 803add6532987c090a52f31ef375211888f304eb (xamarin/md-addins)
Included in Commit: aa067c47ab71e3c2c7af8a5263abb7d329523b09 (mono/monodevelop)
Comment 3 Prashant manu 2016-09-05 08:25:42 UTC
I have checked this with master XS 6.2(build 442) and observed that now this issue is not exits, we are getting msym directory in the archive. Here is the screencast for the same: http://www.screencast.com/t/387ZObVn

@greg.munn@xamarin.com Could you please fix the merge in Cycle 8 lane, so that I can close this issue with C8 XS.

Thanks!
Comment 4 Mohit Kheterpal 2016-09-06 15:18:07 UTC
I have checked this issue and observed that now msym folder is appearing as "mSYM" as shown in screencast : http://www.screencast.com/t/KXNLagGl

Using XS 6.2.0.455

Now please merge the fix in Cycle 8 lane.

thanks
Comment 5 xamarin-release-manager 2016-09-06 15:27:41 UTC
Fixed in version 6.1.0.5419 (cycle8)

Author: Greg Munn
Commit: 54fd6f78c24d815e8ca07f482de5e24d7cbbd6df (xamarin/md-addins)
Included in Commit: fd2694296f1a1967ff85cc3fb4e58613de1dcc05 (mono/monodevelop)
Comment 6 Mohit Kheterpal 2016-09-06 16:51:39 UTC
I have checked this issue and observed that this issue has been fixed with latest build of cycle 8 XS i.e. 6.1.0.5425

Screencast : http://www.screencast.com/t/n86q5j6M

Hence closing this issue.

thanks