Bug 42554

Summary: Typing into the search box is corrupting memory and crashing
Product: [Desktop] Xamarin Studio Reporter: Alan McGovern <alan>
Component: GeneralAssignee: Cody Russell <cody>
Severity: blocker CC: iain.holmes, jatint, luis.aguilera, mono-bugs+monodevelop, shrutis
Priority: High    
Version: unspecified   
Target Milestone: (C8)   
Hardware: PC   
OS: Mac OS   
Tags: Is this bug a regression?: ---
Last known good build:

Description Alan McGovern 2016-07-14 11:41:09 UTC
Repro, just type in the search box: http://screencast.com/t/Iz9cb6jgn

Sample output indicating memory corruption: https://gist.github.com/alanmcgovern/96f5225e1a9e1de535db0a77c2e637ae

Sample crash caused by memory corruption: https://gist.github.com/alanmcgovern/fec347f39b3cfd99267feef57df2eec3
Comment 1 Alan McGovern 2016-07-14 12:13:49 UTC
I started seeing these crashes very recently and I also updated my mono very recently.

I'm using Mono JIT compiler version 4.6.0 (mono-4.6.0-branch/7c372ff Thu Jul 14 02:56:23 EDT 2016) at the moment. This could be a regression in C8 mono.
Comment 6 Shruti 2016-07-22 11:56:19 UTC
Reproduce Status
I have tried to reproduce this issue with larger solution with Mono 4.6.0. I have typed multiple times to search box for searching text and used keyboard arrow keys. After using arrow keys, XS get crashed. I am able to reproduce the XS crash behaviour around 3 times but I am getting different exceptions "ObjCRuntime.RuntimeException: Cannot register two managed types "
IDE Log: https://gist.github.com/shrutis360/fa88a07a785809e044bf104413c48b20
XS Crash report: https://gist.github.com/shrutis360/58f9a81bfb0cdc1dae7c2f1042ebc35a
Environment Info: https://gist.github.com/shrutis360/ee87aa52f0f4db66265318690c1998d7
Screencast: http://www.screencast.com/t/W1tPISiVD1S

Verify Status:
I have checked this issue with patch Mono with multiple behaviour of typo text in search box and used keyboard arrow keys. And XS did not get crashed.
Environment Info:https://gist.github.com/shrutis360/2083aadfc7cb14e760b997234fbaaadc

@Alan, Could you please review it. And I believe we can verify this issue as this issue  is no more exist.
Comment 7 Alan McGovern 2016-07-22 15:29:26 UTC
You triggered the issue with the old build and couldn't with the fixed build, so that looks like the patch worked as expected!
Comment 8 Jatin 2016-08-16 07:41:44 UTC
I have verified this issue with the latest Cycle 8 builds, below is the environment information for the same:

I have observed that this issue is now foxed, as the XS does not crash when type text in search box and used keyboard arrow keys.

Below is the screencast for the same:

Hence, we can close this issue.