Bug 41580

Summary: icon for links is not clear
Product: [Desktop] Xamarin Studio Reporter: Rainer Mager <rainer>
Component: GeneralAssignee: Vsevolod Kukol <sevoku>
Status: VERIFIED FIXED    
Severity: normal CC: masinha, mono-bugs+monodevelop, sachins
Priority: Normal    
Version: 6.0.0 (C7)   
Target Milestone: C7SR1   
Hardware: Macintosh   
OS: Mac OS   
Tags: Is this bug a regression?: ---
Last known good build:

Description Rainer Mager 2016-06-08 04:57:23 UTC
If you have a file in a solution that is a link to another file, the icon does not make that clear and the only way to tell is to look at the file's properties to see where it actually exist in the filesystem. This is a regression from previous versions that added a badge to the icon designating it was a link.
Comment 1 Vsevolod Kukol 2016-06-09 10:23:07 UTC
We have fixed a similar issue on master (https://github.com/mono/monodevelop/commit/e5e9798a9952601ca128fa223c724e8511904b13) where the link icon disappeared when the project was under version control. Can you reproduce it without the project being under version control and attach you Ide log and a screenshot (or a sample project)?
Comment 2 xamarin-release-manager 2016-06-09 11:05:37 UTC
Fixed in version 6.0.1.22 (cycle7)

Author: Lluis Sanchez
Commit: dd5b9b96b69ee2ac93ed7e79c4e81d243c4976a9 (mono/monodevelop)
Comment 3 xamarin-release-manager 2016-06-15 18:46:18 UTC
Fixed in version 6.0.2.19 (cycle7-app-insights-rebased)

Author: Lluis Sanchez
Commit: dd5b9b96b69ee2ac93ed7e79c4e81d243c4976a9 (mono/monodevelop)