Bug 41171

Summary: System.Drawing.Imaging.PngCodecTest.Bitmap2bit* tests fail on Linux ARM64
Product: [Mono] Class Libraries Reporter: Alexander Köplinger [MSFT] <alkpli>
Component: libgdiplusAssignee: Bugzilla <bugzilla>
Status: CONFIRMED ---    
Severity: normal CC: mono-bugs+mono
Priority: ---    
Version: master   
Target Milestone: Untriaged   
Hardware: PC   
OS: Linux   
Tags: Is this bug a regression?: ---
Last known good build:

Description Alexander Köplinger [MSFT] 2016-05-19 00:03:16 UTC
They fail like this on ARM64, smells like a libgdiplus issue:

> MESSAGE:
> System.ArgumentException : A null reference or invalid value was found [GDI+ status: InvalidParameter]
> +++++++++++++++++++
> STACK TRACE:
> at System.Drawing.GDIPlus.CheckStatus (System.Drawing.Status status) [0x0009b] in /media/ssd/jenkins/workspace/test-mono-mainline-linux/label/debian-8-arm64/mcs/class/System.Drawing/System.Drawing/gdipFunctions.cs:212
> at System.Drawing.Bitmap..ctor (System.String filename, System.Boolean useIcm) [0x00034] in /media/ssd/jenkins/workspace/test-mono-mainline-linux/label/debian-8-arm64/mcs/class/System.Drawing/System.Drawing/Bitmap.cs:127
> at System.Drawing.Bitmap..ctor (System.String filename) [0x00000] in /media/ssd/jenkins/workspace/test-mono-mainline-linux/label/debian-8-arm64/mcs/class/System.Drawing/System.Drawing/Bitmap.cs:104
> at (wrapper remoting-invoke-with-check) System.Drawing.Bitmap:.ctor (string)
> at MonoTests.System.Drawing.Imaging.PngCodecTest.Bitmap2bitData () [0x0000c] in /media/ssd/jenkins/workspace/test-mono-mainline-linux/label/debian-8-arm64/mcs/class/System.Drawing/Test/System.Drawing.Imaging/PngCodecTest.cs:354
> at (wrapper managed-to-native) System.Reflection.MonoMethod:InternalInvoke (System.Reflection.MonoMethod,object,object[],System.Exception&)
> at System.Reflection.MonoMethod.Invoke (System.Object obj, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00038] in /media/ssd/jenkins/workspace/test-mono-mainline-linux/label/debian-8-arm64/mcs/class/corlib/System.Reflection/MonoMethod.cs:305
Comment 1 Alexander Köplinger [MSFT] 2016-08-24 22:04:02 UTC
I'm seeing the same issue on the Archlinux Docker job as well: https://jenkins.mono-project.com/job/test-mono-mainline-docker/label=docker-archlinux/82/testReport/MonoTests.System.Drawing.Imaging/PngCodecTest/Bitmap2bitData/

This suggests it's not something to do with ARM64 and rather a general libgdiplus issue (maybe due to newer libpng?).