Bug 39631

Summary: PPDB support fails to load any pdb when verifier is involved
Product: [Mono] Runtime Reporter: Marek Safar <masafa>
Component: DebuggerAssignee: Zoltan Varga <vargaz>
Status: RESOLVED FIXED    
Severity: normal CC: mono-bugs+mono, mono-bugs+runtime
Priority: ---    
Version: unspecified   
Target Milestone: ---   
Hardware: PC   
OS: Mac OS   
Tags: Is this bug a regression?: ---
Last known good build:
Attachments: system.pdb

Description Marek Safar 2016-03-15 09:09:00 UTC
The only error message I get is

Could not load image foo.pdb due to CLI header missing
Comment 1 Zoltan Varga 2016-03-15 09:24:24 UTC
I can't reproduce this, could you attach a .exe/.pdb which fails ?
Comment 2 Marek Safar 2016-03-15 09:27:53 UTC
Created attachment 15403 [details]
system.pdb
Comment 3 Zoltan Varga 2016-03-15 09:40:03 UTC
I copied it next to System.dll, and run a process test using
mono --debug process.exe,
and the file was loaded successfully.
Comment 4 Marek Safar 2016-03-15 09:47:14 UTC
Updated the description, the failure happens when you run mono with "--verify-all"
Comment 5 Zoltan Varga 2016-03-23 21:14:53 UTC
Disabled the verifier for ppdb files for now.