Bug 39077

Summary: AppDomain.CurrentDomain.UnhandledException prevents exceptions in ThreadPool from crashing the application
Product: [Mono] Runtime Reporter: Bryan Maus <bryan.maus>
Component: GeneralAssignee: Ludovic Henry <ludovic>
Status: RESOLVED FIXED    
Severity: normal CC: masafa, mono-bugs+mono, mono-bugs+runtime, paul.ecroyd, rolf, stephan
Priority: ---    
Version: 4.2.0 (C6)   
Target Milestone: ---   
Hardware: PC   
OS: Windows   
Tags: Is this bug a regression?: ---
Last known good build:
Attachments: Test case

Description Bryan Maus 2016-02-23 23:54:16 UTC
See attached test case. It crashes in .NET and doesn't crash in Mono. I tried this on 4.2.1, 3.2.3, and 2.10.8 in Linux and 4.0.1 in Windows.

This may be the related to Bug 34385.
Comment 1 Bryan Maus 2016-02-24 00:12:15 UTC
Created attachment 15157 [details]
Test case
Comment 2 Ludovic Henry 2016-03-02 13:34:50 UTC
This is fixed with https://github.com/mono/mono/pull/2706.

Thank you for your report,
Ludovic
Comment 3 Ludovic Henry 2016-03-04 10:22:22 UTC
*** Bug 34385 has been marked as a duplicate of this bug. ***