Bug 35569

Summary: Can not start inspector: Method 'UIDevice.get_Name' not found.
Product: Workbooks & Inspector Reporter: Philipp <philipp>
Component: Agent: iOSAssignee: inspectordev-discuss
Status: VERIFIED FIXED    
Severity: normal CC: inspectordev-discuss, jamie, Rajneeshk, sandy
Priority: ---    
Version: 0.3.1   
Target Milestone: ---   
Hardware: Macintosh   
OS: Mac OS   
Tags: Is this bug a regression?: ---
Last known good build:

Description Philipp 2015-11-05 04:14:56 UTC
When i try to start the inspector, the app crashes with the following exception:

System.MissingMethodException: Method 'UIDevice.get_Name' not found.
  at at Xamarin.InspectorSupport.<CreateAgent>m__1 () in /Users/builder/data/lanes/904/55ad6a51/source/inspector/Xamarin.Inspector.iOS/InspectorSupport.cs:line 17
  at at Foundation.NSAsyncActionDispatcher.Apply () in /Users/builder/data/lanes/2356/9ce9e8b9/source/maccore/src/Foundation/NSAction.cs:line 163
  at at (wrapper managed-to-native) UIKit.UIApplication:UIApplicationMain (int,string[],intptr,intptr)
  at at UIKit.UIApplication.Main (System.String[] args, IntPtr principal, IntPtr delegate) in /Users/builder/data/lanes/2356/9ce9e8b9/source/maccore/src/UIKit/UIApplication.cs:line 77
  at at UIKit.UIApplication.Main (System.String[] args, System.String principalClassName, System.String delegateClassName) in /Users/builder/data/lanes/2356/9ce9e8b9/source/maccore/src/UIKit/UIApplication.cs:line 61
Comment 1 Sandy Armstrong [MSFT] 2015-11-05 09:44:30 UTC
Hi Philipp. Could you please take a screenshot of your iOS project's "iOS Build" settings?

Mostly I'm curious about the linker settings (because I think disabling the linker might fix this for you), but it might be helpful to see all settings.

Thanks!
Comment 2 Jamie Houston 2015-11-05 15:25:33 UTC
I'm getting the same error.  I'll get a screenshot and try turning off the linker too.
Comment 3 Jamie Houston 2015-11-05 16:44:35 UTC
Changing build config to not link did the trick.  Error is gone.
Comment 4 Sandy Armstrong [MSFT] 2015-11-05 16:49:51 UTC
Excellent. As mentioned in the forums, in my own testing I also got a crash on startup, but with a different error. Fix is in the pipeline and will be in the next release.
Comment 5 Sandy Armstrong [MSFT] 2015-11-05 16:50:27 UTC
And by "fix" I mean we won't enable inspection unless the the linker is fully disabled.
Comment 6 Philipp 2015-11-06 07:28:07 UTC
Turning off the linker also worked for me. Thanks for the quick "fix" :)
Comment 7 Sandy Armstrong [MSFT] 2015-11-16 14:45:22 UTC
Fixed in upcoming release.