Bug 34470

Summary: Can't compile F# app on OS X El Capitan
Product: [Mono] Runtime Reporter: Frank A. Krueger <fak>
Component: packagingAssignee: Duncan Mak <duncan.mak>
Status: VERIFIED FIXED    
Severity: critical CC: chris.hamons, cody.beyer, kumpera, larry.obrien, miguel, mono-bugs+monomac, mono-bugs+mono, mono-bugs+runtime, rolf, sadika
Priority: Highest    
Version: 4.2.0 (C6)   
Target Milestone: ---   
Hardware: Macintosh   
OS: Mac OS   
Tags: Is this bug a regression?: ---
Last known good build:

Description Frank A. Krueger 2015-09-30 18:07:55 UTC
Can't compile app on OS X El Capitan.

When compiling, I get the error:

exec: mono: not found(24)

(full build log below)

This happens on both the Stable and Alpha channels.

Full build log:


Cleaning Solution: Mecha.Mac (Debug)

Cleaning: Mecha (Debug)
Removing output files...
Clean complete

Cleaning: Mecha.Core (Debug)

Build started 9/30/2015 3:04:26 PM.
__________________________________________________
Project "/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Core/Mecha.Core.fsproj" (Clean target(s)):
	
	Target CoreClean:
		Deleting file '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Core/bin/Debug/Mecha.Core.dll.mdb'
		Deleting file '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Core/bin/Debug/Mecha.Core.dll'
		Deleting file '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Core/obj/Debug/Mecha.Core.dll'
		Deleting file '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Core/obj/Debug/Mecha.Core.dll.mdb'
		Deleting file '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Core/bin/Debug/FsLexYacc.Runtime.dll'
		Deleting file '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Core/obj/Debug/Mecha.Core.fsproj.FilesWrittenAbsolute.txt'
Done building project "/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Core/Mecha.Core.fsproj".

Build succeeded.
	 0 Warning(s)
	 0 Error(s)

Time Elapsed 00:00:00.1143860

Cleaning: Mecha.Test (Debug)

Build started 9/30/2015 3:04:26 PM.
__________________________________________________
Project "/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Test/Mecha.Test.fsproj" (Clean target(s)):
	
	Target CoreClean:
		Deleting file '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Test/bin/Debug/Mecha.Test.dll.mdb'
		Deleting file '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Test/bin/Debug/Mecha.Test.dll'
		Deleting file '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Test/obj/Debug/Mecha.Test.dll'
		Deleting file '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Test/obj/Debug/Mecha.Test.dll.mdb'
		Deleting file '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Test/bin/Debug/Mecha.Core.dll'
		Deleting file '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Test/bin/Debug/Mecha.Core.dll.mdb'
		Deleting file '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Test/bin/Debug/FsLexYacc.Runtime.dll'
		Deleting file '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Test/obj/Debug/Mecha.Test.fsproj.FilesWrittenAbsolute.txt'
Done building project "/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Test/Mecha.Test.fsproj".

Build succeeded.
	 0 Warning(s)
	 0 Error(s)

Time Elapsed 00:00:00.1541260

Cleaning: Mecha.PerformanceTest (Debug)

Build started 9/30/2015 3:04:27 PM.
__________________________________________________
Project "/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.PerformanceTest/Mecha.PerformanceTest.fsproj" (Clean target(s)):
	
	Target CoreClean:
		Deleting file '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.PerformanceTest/bin/Debug/Mecha.PerformanceTest.exe.mdb'
		Deleting file '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.PerformanceTest/bin/Debug/Mecha.PerformanceTest.exe'
		Deleting file '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.PerformanceTest/obj/Debug/Mecha.PerformanceTest.exe'
		Deleting file '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.PerformanceTest/obj/Debug/Mecha.PerformanceTest.exe.mdb'
		Deleting file '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.PerformanceTest/bin/Debug/Mecha.Core.dll'
		Deleting file '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.PerformanceTest/bin/Debug/Mecha.Core.dll.mdb'
		Deleting file '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.PerformanceTest/bin/Debug/FsLexYacc.Runtime.dll'
		Deleting file '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.PerformanceTest/obj/Debug/Mecha.PerformanceTest.fsproj.FilesWrittenAbsolute.txt'
Done building project "/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.PerformanceTest/Mecha.PerformanceTest.fsproj".

Build succeeded.
	 0 Warning(s)
	 0 Error(s)

Time Elapsed 00:00:00.1153630

Building Solution: Mecha.Mac (Debug)

Building: Mecha.Core (Debug)

Build started 9/30/2015 3:04:27 PM.
__________________________________________________
Project "/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Core/Mecha.Core.fsproj" (Build target(s)):
	
	Target PrepareForBuild:
		Configuration: Debug Platform: AnyCPU
	
	Target CopyFilesMarkedCopyLocal:
		Copying file from '/Users/fak/Dropbox/Projects/Mecha.Try9/packages/FsLexYacc.Runtime.6.1.0/lib/net40/FsLexYacc.Runtime.dll' to '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Core/bin/Debug/FsLexYacc.Runtime.dll'
	
	Target GenerateSatelliteAssemblies:
	No input files were specified for target GenerateSatelliteAssemblies, skipping.
	
	Target CoreCompile:
		Tool /Library/Frameworks/Mono.framework/Versions/4.2.1/lib/mono/4.5/fsc.exe execution started with arguments: -o:obj/Debug/Mecha.Core.dll -g --noframework --define:DEBUG --optimize- --tailcalls- -r:/Library/Frameworks/Mono.framework/Versions/4.2.1/lib/mono/4.0/mscorlib.dll -r:/Library/Frameworks/Mono.framework/Versions/4.2.1/lib/mono/4.0/FSharp.Core.dll -r:/Library/Frameworks/Mono.framework/Versions/4.2.1/lib/mono/4.0/System.dll -r:/Library/Frameworks/Mono.framework/Versions/4.2.1/lib/mono/4.0/System.Numerics.dll -r:../packages/FsLexYacc.Runtime.6.1.0/lib/net40/FsLexYacc.Runtime.dll -r:/Library/Frameworks/Mono.framework/Versions/4.2.1/lib/mono/4.0/System.Core.dll --target:library --warn:2 --warnaserror:76 --fullpaths --flaterrors --highentropyva- --warnaserror+ AssemblyInfo.fs ListDiff.fs Units.fs Settings.fs Expression.fs Element.fs Evaluator.fs MechaDocument.fs Scad.fs ScadParser.fs ScadLexer.fs TestData.fs Logging.fs ExpressionParsing.fs Matrix.fs Csg.fs Serialization.fs 
		F# Compiler for F# 3.1 (Open Source Edition)
		Freely distributed under the Apache 2.0 Open Source License
	
	Target DeployOutputFiles:
		Copying file from '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Core/obj/Debug/Mecha.Core.dll.mdb' to '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Core/bin/Debug/Mecha.Core.dll.mdb'
		Copying file from '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Core/obj/Debug/Mecha.Core.dll' to '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Core/bin/Debug/Mecha.Core.dll'
Done building project "/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Core/Mecha.Core.fsproj".

Build succeeded.
	 0 Warning(s)
	 0 Error(s)

Time Elapsed 00:00:07.1691080

Building: Mecha (Debug)
Performing main compilation...
/Library/Frameworks/Mono.framework/Versions/4.2.1/bin/fsharpc --noframework --nologo
--target:exe
--out:"/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Mac/bin/Debug/Mecha.exe"
--noframework
-o:/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Mac/bin/Debug/Mecha.exe
--define:DEBUG
--debug:full
--optimize-
--tailcalls-
--warnaserror+
-r:"/Library/Frameworks/Mono.framework/Versions/4.2.1/lib/mono/4.5/FSharp.Core.dll"
-r:"/Library/Frameworks/Mono.framework/Versions/4.2.1/lib/mono/4.5/System.Core.dll"
-r:"/Library/Frameworks/Mono.framework/Versions/4.2.1/lib/mono/4.5/System.Drawing.dll"
-r:"/Library/Frameworks/Mono.framework/Versions/4.2.1/lib/mono/4.5/System.Xml.Linq.dll"
-r:"/Library/Frameworks/Mono.framework/Versions/4.2.1/lib/mono/4.5/System.Xml.dll"
-r:"/Library/Frameworks/Mono.framework/Versions/4.2.1/lib/mono/4.5/System.dll"
-r:"/Library/Frameworks/Mono.framework/Versions/4.2.1/lib/mono/4.5/mscorlib.dll"
-r:"/Library/Frameworks/Xamarin.Mac.framework/Versions/Current/lib/mono/XamMac.dll"
-r:"/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Core/bin/Debug/Mecha.Core.dll"
"/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Mac/Logging.fs"
"/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Mac/AutoLayout.fs"
"/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Mac/Inspector.fs"
"/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Mac/OutlineDataSource.fs"
"/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Mac/MechaSceneView.fs"
"/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Mac/SceneController.fs"
"/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Mac/MyDocument.fs"
"/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Mac/AppDelegate.fs"
Build complete -- 1 error, 0 warnings

Building: Mecha.Test (Debug)

Build started 9/30/2015 3:04:34 PM.
__________________________________________________
Project "/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Test/Mecha.Test.fsproj" (Build target(s)):
	
	Target PrepareForBuild:
		Configuration: Debug Platform: AnyCPU
	
	Target CopyFilesMarkedCopyLocal:
		Copying file from '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Core/bin/Debug/Mecha.Core.dll' to '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Test/bin/Debug/Mecha.Core.dll'
		Copying file from '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Core/bin/Debug/Mecha.Core.dll.mdb' to '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Test/bin/Debug/Mecha.Core.dll.mdb'
		Copying file from '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Core/bin/Debug/FsLexYacc.Runtime.dll' to '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Test/bin/Debug/FsLexYacc.Runtime.dll'
	
	Target GenerateSatelliteAssemblies:
	No input files were specified for target GenerateSatelliteAssemblies, skipping.
	
	Target CoreCompile:
		Tool /Library/Frameworks/Mono.framework/Versions/4.2.1/lib/mono/4.5/fsc.exe execution started with arguments: -o:obj/Debug/Mecha.Test.dll -g --noframework --define:DEBUG --optimize- --tailcalls- -r:/Library/Frameworks/Mono.framework/Versions/4.2.1/lib/mono/4.0/mscorlib.dll -r:/Library/Frameworks/Mono.framework/Versions/4.2.1/lib/mono/4.0/FSharp.Core.dll -r:/Library/Frameworks/Mono.framework/Versions/4.2.1/lib/mono/4.0/System.dll -r:/Library/Frameworks/Mono.framework/Versions/4.2.1/lib/mono/gac/nunit.framework/2.4.8.0__96d09a1eb7f44a77/nunit.framework.dll -r:/Library/Frameworks/Mono.framework/Versions/4.2.1/lib/mono/4.0/System.Core.dll -r:/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Core/bin/Debug//Mecha.Core.dll --target:library --warn:2 --warnaserror:76 --fullpaths --flaterrors --highentropyva- Test.fs RenameVariableTests.fs ScadSerializationTests.fs ExpressionTests.fs 
		F# Compiler for F# 3.1 (Open Source Edition)
		Freely distributed under the Apache 2.0 Open Source License
	
	Target DeployOutputFiles:
		Copying file from '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Test/obj/Debug/Mecha.Test.dll.mdb' to '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Test/bin/Debug/Mecha.Test.dll.mdb'
		Copying file from '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Test/obj/Debug/Mecha.Test.dll' to '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Test/bin/Debug/Mecha.Test.dll'
Done building project "/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Test/Mecha.Test.fsproj".

Build succeeded.
	 0 Warning(s)
	 0 Error(s)


Building: Mecha.PerformanceTest (Debug)

Build started 9/30/2015 3:04:38 PM.
__________________________________________________
Project "/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.PerformanceTest/Mecha.PerformanceTest.fsproj" (Build target(s)):
	
	Target PrepareForBuild:
		Configuration: Debug Platform: AnyCPU
	
	Target CopyFilesMarkedCopyLocal:
		Copying file from '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Core/bin/Debug/Mecha.Core.dll' to '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.PerformanceTest/bin/Debug/Mecha.Core.dll'
		Copying file from '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Core/bin/Debug/Mecha.Core.dll.mdb' to '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.PerformanceTest/bin/Debug/Mecha.Core.dll.mdb'
		Copying file from '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Core/bin/Debug/FsLexYacc.Runtime.dll' to '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.PerformanceTest/bin/Debug/FsLexYacc.Runtime.dll'
	
	Target GenerateSatelliteAssemblies:
	No input files were specified for target GenerateSatelliteAssemblies, skipping.
	
	Target CoreCompile:
		Tool /Library/Frameworks/Mono.framework/Versions/4.2.1/lib/mono/4.5/fsc.exe execution started with arguments: -o:obj/Debug/Mecha.PerformanceTest.exe -g --noframework --define:DEBUG --optimize- --tailcalls- -r:/Library/Frameworks/Mono.framework/Versions/4.2.1/lib/mono/4.0/mscorlib.dll -r:/Library/Frameworks/Mono.framework/Versions/4.2.1/lib/mono/4.0/FSharp.Core.dll -r:/Library/Frameworks/Mono.framework/Versions/4.2.1/lib/mono/4.0/System.dll -r:/Library/Frameworks/Mono.framework/Versions/4.2.1/lib/mono/4.0/System.Numerics.dll -r:/Library/Frameworks/Mono.framework/Versions/4.2.1/lib/mono/4.0/System.Core.dll -r:/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.Core/bin/Debug//Mecha.Core.dll --target:exe --warn:2 --warnaserror:76 --fullpaths --flaterrors --highentropyva- AssemblyInfo.fs Program.fs 
		F# Compiler for F# 3.1 (Open Source Edition)
		Freely distributed under the Apache 2.0 Open Source License
	
	Target DeployOutputFiles:
		Copying file from '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.PerformanceTest/obj/Debug/Mecha.PerformanceTest.exe.mdb' to '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.PerformanceTest/bin/Debug/Mecha.PerformanceTest.exe.mdb'
		Copying file from '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.PerformanceTest/obj/Debug/Mecha.PerformanceTest.exe' to '/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.PerformanceTest/bin/Debug/Mecha.PerformanceTest.exe'
Done building project "/Users/fak/Dropbox/Projects/Mecha.Try9/Mecha.PerformanceTest/Mecha.PerformanceTest.fsproj".

Build succeeded.
	 0 Warning(s)
	 0 Error(s)

Time Elapsed 00:00:02.9084380

---------------------- Done ----------------------

Build: 1 error, 0 warnings



=== Xamarin Studio ===

Version 5.10 (build 800)
Installation UUID: fce13fdd-e8e3-48ef-99f1-4acbb06f0240
Runtime:
	Mono 4.2.1 (explicit/4a18c57)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 402010056

=== Xamarin.Profiler ===

Version: 0.0.0.0
Location: /Users/fak/Downloads/profiler-mac-0-2.9-29/XamarinProfiler.Mac.app/Contents/MacOS/XamarinProfiler.Mac

=== Xamarin.Android ===

Version: 6.0.0.2 (Enterprise Edition)
Android SDK: /Users/fak/Library/Developer/Xamarin/android-sdk-mac_x86
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.3   (API level 18)
		4.4   (API level 19)
		5.0   (API level 21)
		5.1   (API level 22)

SDK Tools Version: 24.1.2
SDK Platform Tools Version: 22
SDK Build Tools Version: 19.1

Java SDK: /usr
java version "1.8.0_20-ea"
Java(TM) SE Runtime Environment (build 1.8.0_20-ea-b23)
Java HotSpot(TM) 64-Bit Server VM (build 25.20-b22, mixed mode)

=== Xamarin Android Player ===

Version: 0.3.7
Location: /Applications/Xamarin Android Player.app

=== Apple Developer Tools ===

Xcode 7.0.1 (8228)
Build 7A1001

=== Xamarin.iOS ===

Version: 9.2.0.67 (Enterprise Edition)
Hash: f85a845
Branch: master
Build date: 2015-09-23 10:34:01-0400

=== Xamarin.Mac ===

Version: 2.4.0.62 (Enterprise Edition)

=== Build Information ===

Release ID: 510000800
Git revision: 92083188182e8c4588153e0d63e99c1a7037e4b6
Build date: 2015-09-18 15:03:06-04
Xamarin addins: 97a862a9dcaa31e9044c8613ef42e0a588c8d012
Build lane: monodevelop-lion-cycle6

=== Operating System ===

Mac OS X 10.11.0
Darwin muon.local 15.0.0 Darwin Kernel Version 15.0.0
    Wed Aug 26 16:57:32 PDT 2015
    root:xnu-3247.1.106~1/RELEASE_X86_64 x86_64
Comment 1 Rolf Bjarne Kvinge [MSFT] 2015-10-01 03:26:38 UTC
This is an F# bug: https://github.com/fsharp/fsharp/blob/master/launcher.in#L24

Reassigning to Mono because it's Mono who's shipping F#, this is not a bug in Xamarin.Mac.
Comment 2 Chris Hamons 2015-10-01 09:39:28 UTC
As a possible work around, I've seen luck in similar issues launching Xamarin Studio via the command line with your PATH set to include the new mono location.

I'm going to work with QA to try to get better F# testing done sooner.
Comment 3 Chris Hamons 2015-10-01 10:25:41 UTC
Alright, I think I have a better work around for this bug if nothing else.

You can edit this file:

/Library/Frameworks/Mono.framework/Versions/4.2.1/bin/fsharpc

and replace mono with /Library/Frameworks/Mono.framework/Commands/mono

I believe that should fix your build until we get this fixed for real.
Comment 4 Frank A. Krueger 2015-10-01 11:40:48 UTC
Well I noticed that Universal F# apps are now working on Alpha (must go through a different build sequence?) so I began the task of converting the code base over.

You can deprioritize on my behalf since I have to make the 64-bit transition anyway.

Thank you for the quick responses!
Comment 5 Chris Hamons 2015-10-01 11:52:15 UTC
Yes. Unified goes through our msbuild pipeline, which is significantly more awesome. Glad to hear that you have a reasonable path forward.
Comment 6 Rodrigo Kumpera 2015-10-01 15:14:42 UTC
Hi Frank,

We're having a hard time to pin down which version of mono you're using.

Do you mind tell us the output of mono --version?

Thanks.
Comment 7 Frank A. Krueger 2015-10-02 14:55:22 UTC
Hi Rodrigo,

I have tried on both the Stable and Alpha channels. Here is the version on Alpha:

$ mono --version
Mono JIT compiler version 4.2.1 (explicit/4a18c57 Mon Sep 21 09:38:36 EDT 2015)
Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
	TLS:           normal
	SIGSEGV:       altstack
	Notification:  kqueue
	Architecture:  x86
	Disabled:      none
	Misc:          softdebug 
	LLVM:          yes(3.6.0svn-mono-(detached/a173357)
	GC:            sgen
Comment 8 Sadik Ali 2015-10-06 11:31:28 UTC
First I have reproduced this issue with latest C6 Mono 4.2.1.62 and with the help of sample project given in bug https://bugzilla.xamarin.com/show_bug.cgi?id=30927. 

Build Output: https://gist.github.com/Rajneesh360Logica/4b969d589b4129915c3a
Screencast: http://www.screencast.com/t/DZH67j5Nxp3
Error: https://gist.github.com/Rajneesh360Logica/9cf7a8cd40c7ded7dc11
Environment Info: https://gist.github.com/Rajneesh360Logica/7fe3d77d9159cafb3e75

Now, I have checked it with mono(MonoFramework-MDK-4.3.0.1438.macos10.xamarin.x86)
and observed that this issue does not exist as shown in screencast : 

http://www.screencast.com/t/pkM6OlsD

Environment Info:

=== Xamarin Studio ===

Version 5.10 (build 812)
Installation UUID: 0922fe35-7ea3-4736-b7b6-9eddaf47d514
Runtime:
	Mono 4.3.0 (master/2a30426)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 403001438

=== Operating System ===

Mac OS X 10.11.0
Darwin 360Logicas-MacBook-Pro.local 15.0.0 Darwin Kernel Version 15.0.0
    Wed Aug 26 16:57:32 PDT 2015
    root:xnu-3247.1.106~1/RELEASE_X86_64 x86_64
Comment 9 Alexis Christoforides 2015-10-13 12:41:59 UTC
*** Bug 34612 has been marked as a duplicate of this bug. ***
Comment 10 Sadik Ali 2015-10-21 07:27:42 UTC
I have checked this issue with latest Cycle 6
MonoFramework-MDK-4.2.1.78.macos10.xamarin.x86_66852f89aad9b04ebbe768ac8141e7ed97c1b2b2 and now this issue is working fine.

Screencast: http://www.screencast.com/t/vYdsOr2s2
Comment 11 Sadik Ali 2015-10-21 07:56:24 UTC
I have checked this issue with latest C5SR5
MonoFramework-MDK-4.0.5.1.macos10.xamarin.x86 and now this issue is working fine.

Screencast: http://www.screencast.com/t/VyRFtejeqV
Environment Info: https://gist.github.com/Rajneesh360Logica/26ee89bdebe423e708f7