Bug 31369

Summary: CodeDom can't compile code on El Capitan
Product: [Mono] Class Libraries Reporter: Rolf Bjarne Kvinge [MSFT] <rolf>
Component: SystemAssignee: Bugzilla <bugzilla>
Status: RESOLVED FIXED    
Severity: normal CC: miguel, mono-bugs+mono
Priority: ---    
Version: master   
Target Milestone: Untriaged   
Hardware: PC   
OS: Mac OS   
Tags: Is this bug a regression?: ---
Last known good build:

Description Rolf Bjarne Kvinge [MSFT] 2015-06-25 06:04:01 UTC
Since it relies on having mcs in PATH: https://github.com/mono/mono/blob/master/mcs/class/System/Microsoft.CSharp/CSharpCodeCompiler.cs#L176
Comment 1 Rolf Bjarne Kvinge [MSFT] 2015-06-25 06:04:51 UTC
The same is true for vbnc: https://github.com/mono/mono/blob/master/mcs/class/System/Microsoft.VisualBasic/VBCodeCompiler.cs#L246
Comment 2 Miguel de Icaza [MSFT] 2015-06-25 13:57:42 UTC
Fixed in mono/master:

e13ecbe24389549361c905f61398f61f188d5b37

Passes all the tests, where should this be landed?
Comment 3 Rolf Bjarne Kvinge [MSFT] 2015-06-26 07:55:13 UTC
I've backported it to the mono-4.2.0-pre-branch (c6f0e4b6804b2d0d9ff5c29b3f27526c9c1b9d77)