Bug 31060

Summary: F# sprintf AOT bug happens still now.
Product: iOS Reporter: Masahiko Miyasaka <miyasaka_masahiko>
Component: Mono runtime / AOT compilerAssignee: Zoltan Varga <vargaz>
Status: RESOLVED FIXED    
Severity: normal CC: fak, gouri.kumari, kumpera, mohitk, mono-bugs+monotouch, rolf
Priority: ---    
Version: XI 8.9.x (iOS 8.3)   
Target Milestone: 8.13 (C6 alpha)   
Hardware: PC   
OS: Windows   
Tags: Is this bug a regression?: ---
Last known good build:
Attachments: repro code and result log

Description Masahiko Miyasaka 2015-06-12 07:05:22 UTC
As you told, I create new issue.
F# sprintf AOT bug happens still now.
The results are little bit different on ARM7s and on ARM64.
Anyway sprintf with 4 or 5 parameters causes crash.
I attached repro code with result text.
I hope you solve this probrem...
Comment 1 Masahiko Miyasaka 2015-06-12 07:06:08 UTC
Created attachment 11584 [details]
repro code and result log
Comment 2 Zoltan Varga 2015-06-12 11:36:24 UTC
This happens because the following method is not found at runtime (on arm64):

(char *) $1 = 0x000000015c5e39d0 "(wrapper runtime-invoke) <Module>:runtime_invoke_object_object_object_object_object_object_object_object_object_object (object,intptr,intptr,intptr)"
Comment 3 Masahiko Miyasaka 2015-06-12 12:09:51 UTC
Why it's not found?
Comment 4 Zoltan Varga 2015-06-12 12:55:13 UTC
This will be fixed in an upcoming xamarin.ios version.
Comment 5 Masahiko Miyasaka 2015-06-12 20:54:10 UTC
When will you release fixed version? can I confirm it with alpha version?
Comment 6 Zoltan Varga 2015-06-12 20:58:35 UTC
It is target at xamarin.ios 8.12.
Comment 7 Masahiko Miyasaka 2015-06-12 21:02:36 UTC
Do u know when it will come as stable?
Our release date is coming...
Comment 8 Zoltan Varga 2015-06-12 21:21:10 UTC
You can work around it by passing less parameters to sprintf.
Comment 9 Masahiko Miyasaka 2015-06-12 21:43:12 UTC
I know it. But if u solve I don't have to do it.
If your release doesn't match our release date ,I ll do it.
Comment 13 Zoltan Varga 2015-07-20 17:17:03 UTC
The arm64 version of the fix was not backported, now it is backported as 
maccore/macios-cycle5-c5sr3:c872646797598b4e8013e15fc1ec19dce7effbd7
Comment 14 Zoltan Varga 2015-07-20 17:29:13 UTC
The propert xi commit is:
maccore/macios-cycle5-c5sr3:099f94bba4532201864249a9064bf73be56f8667
Comment 15 Zoltan Varga 2015-07-20 17:34:40 UTC
It looks like this still doesn't work on arm64. I'd suggest pushing this off to a later release.
Comment 16 Rolf Bjarne Kvinge [MSFT] 2015-08-07 03:38:59 UTC
*** Bug 32846 has been marked as a duplicate of this bug. ***
Comment 17 Rolf Bjarne Kvinge [MSFT] 2015-08-07 03:39:49 UTC
OK, closing so that QA can confirm for 8.12 / 9.0 as per comment #16.