Bug 30880

Summary: IPv4Mask property produces a Not Implemented Exception
Product: iOS Reporter: Andrew Page <andrew.e.page>
Component: BCL Class LibrariesAssignee: Marek Safar <masafa>
Status: RESOLVED DUPLICATE    
Severity: normal CC: curtis.harrison, kumpera, masafa, mono-bugs+monotouch, shrutis
Priority: ---    
Version: master   
Target Milestone: Untriaged   
Hardware: PC   
OS: Mac OS   
Tags: Is this bug a regression?: ---
Last known good build:
Attachments: Sample Project Demonstrating issue. Cleaned, packages removed

Description Andrew Page 2015-06-07 18:05:14 UTC
Created attachment 11498 [details]
Sample Project Demonstrating issue.   Cleaned, packages removed

Attempting to access the UnicastIPAddressInformation IPv4Mask property produces a Not Implemented Exception

	public void IPV4MaskIssueTest()
		{
			IPAddress mask = null ;
			foreach (NetworkInterface ni in NetworkInterface.GetAllNetworkInterfaces()) {
				foreach (UnicastIPAddressInformation uni in ni.GetIPProperties().UnicastAddresses) {	
					Console.WriteLine("ip mask = {0}", uni.IPv4Mask);
					mask = uni.IPv4Mask;
				}

			}
			Assert.IsNotNull(mask, "mask was not found");

		}
Comment 1 Marek Safar 2015-06-18 11:25:50 UTC
Fixed in master
Comment 2 Shruti 2015-08-05 09:46:23 UTC

*** This bug has been marked as a duplicate of bug 30879 ***
Comment 3 Marek Safar 2016-05-25 10:25:49 UTC
*** Bug 27485 has been marked as a duplicate of this bug. ***