Bug 29639

Summary: Moq related Nunit tests fail with RemoteException (Unix transport error) since Mono 4.0
Product: [Mono] Class Libraries Reporter: Michal Domanski <michalwdomanski>
Component: SystemAssignee: Bugzilla <bugzilla>
Status: VERIFIED FIXED    
Severity: normal CC: cody.beyer, damien, eoinmullan, masafa, michalwdomanski, miguel, mono-bugs+mono, shrutis, stephan
Priority: Normal    
Version: master   
Target Milestone: Untriaged   
Hardware: Macintosh   
OS: Mac OS   
Tags: Is this bug a regression?: ---
Last known good build:
Attachments: This solution contains one unit test, which ran with Mono 3.12.1 but won't work with Mono 4.0.0 when executed with nUnit

Description Michal Domanski 2015-05-01 07:55:31 UTC
Created attachment 11015 [details]
This solution contains one unit test, which ran with Mono 3.12.1 but won't work with Mono 4.0.0 when executed with nUnit

Issue :

Since I updated from Mono 3.12.1 to Mono 4.0.0, about 400 of my unit test fail with a RemoteException: Unix transport error, when executing them with nUnit 2.4.8. Downgrading back to Mono 3.12.1 will fix this issue again.

Expected :

nUnit tests that worked with Mono 3.12.1 will work with Mono 4.0.0 as well. (There is no special code magic involved, as may be seen in the attachment)

Description :

I isolated one of the failing tests and removed as much code as possible, until I came up with the solution attached below. It seems the issue (in this one case) is related to the Moq (4.2.1502.0911) framework in conjunction with generic method arguments. When building the solution using "xbuild" and then running "nunit-console" on the built dll, I will get the following output :



NUnit version 2.4.8
Copyright (C) 2002-2007 Charlie Poole.
Copyright (C) 2002-2004 James W. Newkirk, Michael C. Two, Alexei A. Vorontsov.
Copyright (C) 2000-2002 Philip Craig.
All Rights Reserved.

Runtime Environment - 
   OS Version: Unix 14.4.0.0
  CLR Version: 4.0.30319.17020 ( 4.0.0 ((detached/d136b79 Mon Apr 13 14:40:59 EDT 2015) )

.* Assertion at sgen-alloc.c:460, condition `*p == NULL' not met

Stacktrace:

  at <unknown> <0xffffffff>
  at Castle.Proxies.ITestFactoryProxy.GetObservableControllers<T> () <IL 0x00052, 0x0012f>
  at Mono4Bugs.MoqTest.ElementFocused_NotifiesView () [0x0000b] in /Users/Sulix/Documents/Mono4Bugs/Mono4Bugs/MoqTest.cs:13
  at (wrapper runtime-invoke) object.runtime_invoke_void__this__ (object,intptr,intptr,intptr) <IL 0x0005e, 0xffffffff>
  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) System.Reflection.MonoMethod.InternalInvoke (System.Reflection.MonoMethod,object,object[],System.Exception&) <IL 0x00038, 0xffffffff>
  at System.Reflection.MonoMethod.Invoke (object,System.Reflection.BindingFlags,System.Reflection.Binder,object[],System.Globalization.CultureInfo) [0x00054] in /private/tmp/source-mono-mac-4.0.0-branch/bockbuild-mono-4.0.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.0.0/mcs/class/corlib/System.Reflection/MonoMethod.cs:230
  at System.Reflection.MethodBase.Invoke (object,object[]) [0x00000] in /private/tmp/source-mono-mac-4.0.0-branch/bockbuild-mono-4.0.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.0.0/mcs/class/corlib/System.Reflection/MethodBase.cs:114
  at NUnit.Core.Reflect.InvokeMethod (System.Reflection.MethodInfo,object,object[]) [0x0000c] in /private/tmp/source-mono-mac-4.0.0-branch/bockbuild-mono-4.0.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.0.0/mcs/nunit24/NUnitCore/core/Reflect.cs:412
  at NUnit.Core.Reflect.InvokeMethod (System.Reflection.MethodInfo,object) [0x00000] in /private/tmp/source-mono-mac-4.0.0-branch/bockbuild-mono-4.0.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.0.0/mcs/nunit24/NUnitCore/core/Reflect.cs:397
  at NUnit.Core.TestMethod.RunTestMethod (NUnit.Core.TestCaseResult) [0x00000] in /private/tmp/source-mono-mac-4.0.0-branch/bockbuild-mono-4.0.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.0.0/mcs/nunit24/NUnitCore/core/TestMethod.cs:254
  at NUnit.Core.TestMethod.doTestCase (NUnit.Core.TestCaseResult) [0x00000] in /private/tmp/source-mono-mac-4.0.0-branch/bockbuild-mono-4.0.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.0.0/mcs/nunit24/NUnitCore/core/TestMethod.cs:237
  at NUnit.Core.TestMethod.doRun (NUnit.Core.TestCaseResult) [0x00028] in /private/tmp/source-mono-mac-4.0.0-branch/bockbuild-mono-4.0.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.0.0/mcs/nunit24/NUnitCore/core/TestMethod.cs:195
  at NUnit.Core.TestMethod.Run (NUnit.Core.TestCaseResult) [0x00077] in /private/tmp/source-mono-mac-4.0.0-branch/bockbuild-mono-4.0.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.0.0/mcs/nunit24/NUnitCore/core/TestMethod.cs:164
  at NUnit.Core.NUnitTestMethod.Run (NUnit.Core.TestCaseResult) [0x00000] in /private/tmp/source-mono-mac-4.0.0-branch/bockbuild-mono-4.0.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.0.0/mcs/nunit24/NUnitCore/core/NUnitTestMethod.cs:32
  at NUnit.Core.TestCase.Run (NUnit.Core.EventListener) [0x0004f] in /private/tmp/source-mono-mac-4.0.0-branch/bockbuild-mono-4.0.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.0.0/mcs/nunit24/NUnitCore/core/TestCase.cs:58
  at NUnit.Core.TestCase.Run (NUnit.Core.EventListener,NUnit.Core.ITestFilter) [0x00000] in /private/tmp/source-mono-mac-4.0.0-branch/bockbuild-mono-4.0.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.0.0/mcs/nunit24/NUnitCore/core/TestCase.cs:42
  at NUnit.Core.TestSuite.RunAllTests (NUnit.Core.TestSuiteResult,NUnit.Core.EventListener,NUnit.Core.ITestFilter) [0x00071] in /private/tmp/source-mono-mac-4.0.0-branch/bockbuild-mono-4.0.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.0.0/mcs/nunit24/NUnitCore/core/TestSuite.cs:288
  at NUnit.Core.TestSuite.Run (NUnit.Core.EventListener,NUnit.Core.ITestFilter) [0x0008c] in /private/tmp/source-mono-mac-4.0.0-branch/bockbuild-mono-4.0.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.0.0/mcs/nunit24/NUnitCore/core/TestSuite.cs:166
  at NUnit.Core.TestFixture.Run (NUnit.Core.EventListener,NUnit.Core.ITestFilter) [0x00016] in /private/tmp/source-mono-mac-4.0.0-branch/bockbuild-mono-4.0.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.0.0/mcs/nunit24/NUnitCore/core/TestFixture.cs:35
  at NUnit.Core.TestSuite.RunAllTests (NUnit.Core.TestSuiteResult,NUnit.Core.EventListener,NUnit.Core.ITestFilter) [0x00071] in /private/tmp/source-mono-mac-4.0.0-branch/bockbuild-mono-4.0.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.0.0/mcs/nunit24/NUnitCore/core/TestSuite.cs:288
  at NUnit.Core.TestSuite.Run (NUnit.Core.EventListener,NUnit.Core.ITestFilter) [0x0008c] in /private/tmp/source-mono-mac-4.0.0-branch/bockbuild-mono-4.0.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.0.0/mcs/nunit24/NUnitCore/core/TestSuite.cs:166
  at NUnit.Core.TestSuite.RunAllTests (NUnit.Core.TestSuiteResult,NUnit.Core.EventListener,NUnit.Core.ITestFilter) [0x00071] in /private/tmp/source-mono-mac-4.0.0-branch/bockbuild-mono-4.0.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.0.0/mcs/nunit24/NUnitCore/core/TestSuite.cs:288
  at NUnit.Core.TestSuite.Run (NUnit.Core.EventListener,NUnit.Core.ITestFilter) [0x0008c] in /private/tmp/source-mono-mac-4.0.0-branch/bockbuild-mono-4.0.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.0.0/mcs/nunit24/NUnitCore/core/TestSuite.cs:166
  at NUnit.Core.SimpleTestRunner.Run (NUnit.Core.EventListener,NUnit.Core.ITestFilter) [0x0002d] in /private/tmp/source-mono-mac-4.0.0-branch/bockbuild-mono-4.0.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.0.0/mcs/nunit24/NUnitCore/core/SimpleTestRunner.cs:145
  at NUnit.Core.TestRunnerThread.TestRunnerThreadProc () [0x00000] in /private/tmp/source-mono-mac-4.0.0-branch/bockbuild-mono-4.0.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.0.0/mcs/nunit24/NUnitCore/core/TestRunnerThread.cs:149
  at System.Threading.Thread.StartInternal () [0x00016] in /private/tmp/source-mono-mac-4.0.0-branch/bockbuild-mono-4.0.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.0.0/mcs/class/corlib/System.Threading/Thread.cs:696
  at (wrapper runtime-invoke) object.runtime_invoke_void__this__ (object,intptr,intptr,intptr) <IL 0x0005e, 0xffffffff>

Native stacktrace:

	0   mono                                0x00188af6 mono_handle_native_sigsegv + 342
	1   mono                                0x001d9071 sigabrt_signal_handler + 129
	2   libsystem_platform.dylib            0x9b3f403b _sigtramp + 43
	3   ???                                 0xffffffff 0x0 + 4294967295
	4   libsystem_c.dylib                   0x99d33eee abort + 156
	5   mono                                0x00328971 monoeg_log_default_handler + 129
	6   mono                                0x00328a6b monoeg_assertion_message + 107
	7   mono                                0x002ea953 mono_gc_try_alloc_obj_nolock + 739
	8   mono                                0x002eaff1 mono_gc_alloc_string + 65
	9   mono                                0x0029bf8d mono_string_new_size + 109
	10  mono                                0x0029f5dc mono_ldstr_metadata_sig + 60
	11  mono                                0x002a2c85 mono_ldstr + 101
	12  mono                                0x000e72b1 mono_method_to_ir + 30417
	13  mono                                0x000d1c7a mini_method_compile + 3754
	14  mono                                0x000d46f5 mono_jit_compile_method_with_opt + 1669
	15  mono                                0x000d4019 mono_jit_compile_method + 57
	16  mono                                0x0018a201 common_call_trampoline + 961
	17  mono                                0x00189e2c mono_magic_trampoline + 60
	18  ???                                 0x004fa088 0x0 + 5218440

Debug info from gdb:

(lldb) command source -s 1 '/tmp/mono-gdb-commands.SGl6mW'
warning: (i386) /Library/Frameworks/Mono.framework/Versions/4.0.0/lib/mono/4.5/mscorlib.dll.dylib empty dSYM file detected, dSYM was created with an executable with no debug info.
Process 5672 detached
(lldb) 
=================================================================
Got a SIGABRT while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries 
used by your application.
=================================================================

Abort trap: 6




It is notable though that using "int" instead of the interface as the generic argument within the provided unit test will actually fix the unit test. I can isolate further unit tests from my solution if you want me to, but I think this sole issue will  already be very useful to you.
Comment 1 eoinmullan 2015-05-04 09:07:56 UTC
Seeing the same issue since updating to Mono 4.0.0. All the details are identical to the original bug report.

The only information I can add is that this also happens when using the Rhino.Mocks, FakeItEasy or Simple.Mocking.
Comment 2 Marek Safar 2015-05-07 12:30:23 UTC
Already fixed in mono master
Comment 3 Miguel de Icaza [MSFT] 2015-05-13 17:08:26 UTC
@marek is there a chance we can get this backported?
Comment 4 Marek Safar 2015-05-14 12:05:51 UTC
Sure, it just took some time to find the right commit amongst 2000 or so we are behind

This seems to fix the issue https://github.com/mono/mono/commit/ffd38a0fa4c1dc09db2ac3277dc642707ba3f474
Comment 5 Shruti 2015-05-27 03:22:21 UTC
First, I have reproduced this issue on Stable Mono 4.0.0.143 and able to reproduce this issue. Screencast for reproducing issue is http://www.screencast.com/t/3HBDHlBahKQ.

Then I have verified this issue with latest Master Mono 4.1.0.1736 and it is working fine with this build. Test case is passed successfully.
Screencast of verified issue : http://www.screencast.com/t/pjcDdKIy

Environment Info: https://gist.github.com/Shruti360/6a0f4db255e005cc4f0e
Comment 6 Damien Joldersma 2015-07-14 17:48:26 UTC
Greetings, 

Encountered this issue with 4.0.0.143 and was looking forward to next stable package to come out and was hoping the fix that @Shruti mentioned in 4.1.0.1736.

Just tried new stable package 4.0.2.5 but it appears it still a problem. 

Apologies for newb question, but is this fix ever going to get into the 4.0.x series? I've reviewed the mono version document but do not immediately understand what our plan to migrate to mono 4.  Do we have to wait until 4.2.x series in stable?

Our unit and integration tests are not able to run, monodevelop complains about "RemotingException: Unix transport error" and command line nunit-console complains about "Assertion at sgen-alloc.c:460, condition `*p == NULL' not met", see details below.

Here are some relevant package versions:

mono-complete  4.0.2.5-0xamarin1
nunit 2.6.3+dfsg-1~xamarin2
monodevelop 5.9.4.5-0xamarin2

If anyone is interested or if it helps, here is a stack trace:

NUnit-Console version 2.6.3.0
Copyright (C) 2002-2012 Charlie Poole.
Copyright (C) 2002-2004 James W. Newkirk, Michael C. Two, Alexei A. Vorontsov.
Copyright (C) 2000-2002 Philip Craig.
All Rights Reserved.

Runtime Environment - 
   OS Version: Unix 3.16.0.41
  CLR Version: 4.0.30319.17020 ( Mono 4.0 ( 4.0.2 (Stable 4.0.2.5/c99aa0c Wed Jun 24 10:04:37 UTC 2015) ) )

ProcessModel: Default    DomainUsage: Single
Execution Runtime: mono-4.0
Excluded categories: not IntegrationTest
.N* Assertion at sgen-alloc.c:460, condition `*p == NULL' not met

Stacktrace:

  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) System.Reflection.MonoMethod.InternalInvoke (System.Reflection.MonoMethod,object,object[],System.Exception&) <0xffffffff>
  at System.Reflection.MonoMethod.Invoke (object,System.Reflection.BindingFlags,System.Reflection.Binder,object[],System.Globalization.CultureInfo) <0x000f2>
  at System.Reflection.MethodBase.Invoke (object,object[]) <0x0002a>
  at NUnit.Core.Reflect.InvokeMethod (System.Reflection.MethodInfo,object,object[]) <0x00064>
  at NUnit.Core.Reflect.InvokeMethod (System.Reflection.MethodInfo,object) <0x00013>
  at NUnit.Core.TestSuite.DoOneTimeSetUp (NUnit.Core.TestResult) <0x00157>
  at NUnit.Core.NUnitTestFixture.DoOneTimeSetUp (NUnit.Core.TestResult) <0x00017>
  at NUnit.Core.TestSuite.RunSuite (NUnit.Core.EventListener,NUnit.Core.ITestFilter) <0x000be>
  at NUnit.Core.TestSuite.RunSuiteInContext (NUnit.Core.EventListener,NUnit.Core.ITestFilter) <0x000c7>
  at NUnit.Core.TestSuite.Run (NUnit.Core.EventListener,NUnit.Core.ITestFilter) <0x0006f>
  at NUnit.Core.TestFixture.Run (NUnit.Core.EventListener,NUnit.Core.ITestFilter) <0x00083>
  at NUnit.Core.TestSuite.RunAllTests (NUnit.Core.TestResult,NUnit.Core.EventListener,NUnit.Core.ITestFilter) <0x002f1>
  at NUnit.Core.TestSuite.RunSuite (NUnit.Core.EventListener,NUnit.Core.ITestFilter) <0x0046b>
  at NUnit.Core.TestSuite.RunSuiteInContext (NUnit.Core.EventListener,NUnit.Core.ITestFilter) <0x000c7>
  at NUnit.Core.TestSuite.Run (NUnit.Core.EventListener,NUnit.Core.ITestFilter) <0x0006f>
  at NUnit.Core.TestSuite.RunAllTests (NUnit.Core.TestResult,NUnit.Core.EventListener,NUnit.Core.ITestFilter) <0x002f1>
  at NUnit.Core.TestSuite.RunSuite (NUnit.Core.EventListener,NUnit.Core.ITestFilter) <0x0046b>
  at NUnit.Core.TestSuite.RunSuiteInContext (NUnit.Core.EventListener,NUnit.Core.ITestFilter) <0x000c7>
  at NUnit.Core.TestSuite.Run (NUnit.Core.EventListener,NUnit.Core.ITestFilter) <0x0006f>
  at NUnit.Core.TestSuite.RunAllTests (NUnit.Core.TestResult,NUnit.Core.EventListener,NUnit.Core.ITestFilter) <0x002f1>
  at NUnit.Core.TestSuite.RunSuite (NUnit.Core.EventListener,NUnit.Core.ITestFilter) <0x0046b>
  at NUnit.Core.TestSuite.RunSuiteInContext (NUnit.Core.EventListener,NUnit.Core.ITestFilter) <0x000c7>
  at NUnit.Core.TestSuite.Run (NUnit.Core.EventListener,NUnit.Core.ITestFilter) <0x0006f>
  at NUnit.Core.TestSuite.RunAllTests (NUnit.Core.TestResult,NUnit.Core.EventListener,NUnit.Core.ITestFilter) <0x002f1>
  at NUnit.Core.TestSuite.RunSuite (NUnit.Core.EventListener,NUnit.Core.ITestFilter) <0x0046b>
  at NUnit.Core.TestSuite.RunSuiteInContext (NUnit.Core.EventListener,NUnit.Core.ITestFilter) <0x000c7>
  at NUnit.Core.TestSuite.Run (NUnit.Core.EventListener,NUnit.Core.ITestFilter) <0x0006f>
  at NUnit.Core.SimpleTestRunner.Run (NUnit.Core.EventListener,NUnit.Core.ITestFilter,bool,NUnit.Core.LoggingThreshold) <0x00128>
  at NUnit.Core.TestRunnerThread.TestRunnerThreadProc () <0x00059>
  at System.Threading.Thread.StartInternal () <0x00071>
  at (wrapper runtime-invoke) object.runtime_invoke_void__this__ (object,intptr,intptr,intptr) <0xffffffff>

Native stacktrace:

	/usr/bin/cli() [0x4b20bc]
	/lib/x86_64-linux-gnu/libpthread.so.0(+0xfc90) [0x7f3d877c5c90]
	/lib/x86_64-linux-gnu/libc.so.6(gsignal+0x37) [0x7f3d87428e37]
	/lib/x86_64-linux-gnu/libc.so.6(abort+0x148) [0x7f3d8742a528]
	/usr/bin/cli() [0x6294f9]
	/usr/bin/cli() [0x629707]
	/usr/bin/cli() [0x629856]
	/usr/bin/cli() [0x5e68cf]
	/usr/bin/cli() [0x5e6ff0]
	/usr/bin/cli(mono_object_new_alloc_specific+0x1a) [0x5a9f8a]
	/usr/bin/cli(mono_object_new_specific+0x88) [0x5aa068]
	/usr/bin/cli(mono_exception_from_token+0x42) [0x52dde2]
	[0x4068d900]

Debug info from gdb:

[New LWP 9661]
[New LWP 9660]
[New LWP 9659]
[New LWP 9658]
[New LWP 9657]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
185	../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S: No such file or directory.
  Id   Target Id         Frame 
  6    Thread 0x7f3d8664a700 (LWP 9657) "Finalizer" sem_wait () at ../nptl/sysdeps/unix/sysv/linux/x86_64/sem_wait.S:85
  5    Thread 0x7f3d842b5700 (LWP 9658) "cli" 0x00007f3d877c503d in accept () at ../sysdeps/unix/syscall-template.S:81
  4    Thread 0x7f3d7ffff700 (LWP 9659) "Timer-Scheduler" pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:238
  3    Thread 0x7f3d7f887700 (LWP 9660) "cli" pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
  2    Thread 0x7f3d7f686700 (LWP 9661) "cli" 0x00007f3d877c5839 in __libc_waitpid (pid=9662, stat_loc=0x7f3d7f68328c, options=0) at ../sysdeps/unix/sysv/linux/waitpid.c:40
* 1    Thread 0x7f3d882df7c0 (LWP 9656) "cli" pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185

Thread 6 (Thread 0x7f3d8664a700 (LWP 9657)):
#0  sem_wait () at ../nptl/sysdeps/unix/sysv/linux/x86_64/sem_wait.S:85
#1  0x000000000061e898 in mono_sem_wait ()
#2  0x00000000005a1e4e in ?? ()
#3  0x0000000000587188 in ?? ()
#4  0x00000000006236c6 in ?? ()
#5  0x00007f3d877be0a5 in start_thread (arg=0x7f3d8664a700) at pthread_create.c:309
#6  0x00007f3d874ebcfd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 5 (Thread 0x7f3d842b5700 (LWP 9658)):
#0  0x00007f3d877c503d in accept () at ../sysdeps/unix/syscall-template.S:81
#1  0x000000000060b50d in ?? ()
#2  0x0000000000577253 in ?? ()
#3  0x00000000401d7e41 in ?? ()
#4  0x00007f3d78001450 in ?? ()
#5  0x00007f3d842b4e00 in ?? ()
#6  0x00007f3d860beb58 in ?? ()
#7  0x00007f3d860beb58 in ?? ()
#8  0xffffffffffffffff in ?? ()
#9  0x00007f3d78000bd0 in ?? ()
#10 0x00000000401d79ae in ?? ()
#11 0x00007f3d842b49c0 in ?? ()
#12 0x00007f3d842b4910 in ?? ()
#13 0x00000000401d7810 in ?? ()
#14 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f3d7ffff700 (LWP 9659)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:238
#1  0x00000000005fda77 in ?? ()
#2  0x000000000061077c in ?? ()
#3  0x0000000000585c3e in ?? ()
#4  0x0000000000586bb9 in ?? ()
#5  0x000000004058308d in ?? ()
#6  0x0000000000000001 in ?? ()
#7  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f3d7f887700 (LWP 9660)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00000000005fdb0b in ?? ()
#2  0x000000000061094b in ?? ()
#3  0x00000000005a4bfa in ?? ()
#4  0x00000000405fb948 in ?? ()
#5  0x00007f3d74001450 in ?? ()
#6  0x00007f3d7f886e00 in ?? ()
#7  0x00007f3d86008360 in ?? ()
#8  0x00007f3d7fa0c170 in ?? ()
#9  0xffffffffffffffff in ?? ()
#10 0x00007f3d6c000bd0 in ?? ()
#11 0x00007f3d86136378 in ?? ()
#12 0x00007f3d7f8869a0 in ?? ()
#13 0x00007f3d7f8868e0 in ?? ()
#14 0x00000000405fb561 in ?? ()
#15 0x00007f3d7f9a54f0 in ?? ()
#16 0x0000000000000001 in ?? ()
#17 0x00007f3d7f886a01 in ?? ()
#18 0x00000000405fb49f in ?? ()
#19 0x00007f3d7fa0c170 in ?? ()
#20 0x00000000405fb3bf in ?? ()
#21 0x00007f3d7f886901 in ?? ()
#22 0x00007f3d7fa0c170 in ?? ()
#23 0x00007f3d7f886a70 in ?? ()
#24 0x0000000040582926 in ?? ()
#25 0x00007f3d86008360 in ?? ()
#26 0x00007f3d86008360 in ?? ()
#27 0x00007f3d86008360 in ?? ()
#28 0x00007f3d86008360 in ?? ()
#29 0x00007f3d7f886a70 in ?? ()
#30 0x00000000405fae28 in ?? ()
#31 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f3d7f686700 (LWP 9661)):
#0  0x00007f3d877c5839 in __libc_waitpid (pid=9662, stat_loc=0x7f3d7f68328c, options=0) at ../sysdeps/unix/sysv/linux/waitpid.c:40
#1  0x00000000004b2149 in ?? ()
#2  <signal handler called>
#3  0x00007f3d87428e37 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#4  0x00007f3d8742a528 in __GI_abort () at abort.c:89
#5  0x00000000006294f9 in ?? ()
#6  0x0000000000629707 in ?? ()
#7  0x0000000000629856 in ?? ()
#8  0x00000000005e68cf in ?? ()
#9  0x00000000005e6ff0 in ?? ()
#10 0x00000000005a9f8a in mono_object_new_alloc_specific ()
#11 0x00000000005aa068 in mono_object_new_specific ()
#12 0x000000000052dde2 in mono_exception_from_token ()
#13 0x000000004068d900 in ?? ()
#14 0x00000000401990d2 in ?? ()
#15 0x000000004068d8f0 in ?? ()
#16 0x00007f3d7f6845f0 in ?? ()
#17 0x0000000040679eca in ?? ()
#18 0x00007f3d861d30a0 in ?? ()
#19 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f3d882df7c0 (LWP 9656)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00000000005fdb0b in ?? ()
#2  0x000000000061094b in ?? ()
#3  0x0000000000586e86 in ?? ()
#4  0x00000000405fbb3e in ?? ()
#5  0x00007f3d7f9de500 in ?? ()
#6  0x00007f3d863b25c0 in ?? ()
#7  0x00007f3d863b21a0 in ?? ()
#8  0x0000000000000001 in ?? ()
#9  0x00007f3d86008588 in ?? ()
#10 0x00007ffddcbf5800 in ?? ()
#11 0x00000000405fbac6 in ?? ()
#12 0x00007ffddcbf5730 in ?? ()
#13 0x00007ffddcbf55b0 in ?? ()
#14 0x00000000405fbabd in ?? ()
#15 0x00007f3d860084a8 in ?? ()
#16 0x00007f3d8826e580 in ?? ()
#17 0x00007ffddcbf5730 in ?? ()
#18 0x00000000405fb8bd in ?? ()
#19 0x00007f3d7f9de500 in ?? ()
#20 0x00000000405fb634 in ?? ()
#21 0x00007f3d7f9de500 in ?? ()
#22 0x00000000405fb4e4 in ?? ()
#23 0x00007f3d863b25c0 in ?? ()
#24 0x00000000405fac3e in ?? ()
#25 0x00007f3d861aba90 in ?? ()
#26 0x00007f3d863b25c0 in ?? ()
#27 0x00007f3d863abae0 in ?? ()
#28 0x0000000000000001 in ?? ()
#29 0x0000000000000000 in ?? ()

=================================================================
Got a SIGABRT while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries 
used by your application.
=================================================================

Aborted (core dumped)