Bug 2912

Summary: AutoSize behavior of FlowLayoutPanel broken
Product: [Mono] Class Libraries Reporter: eb1
Component: Windows.FormsAssignee: Bugzilla <bugzilla>
Status: RESOLVED FIXED    
Severity: normal CC: miguel, mono-bugs+mono
Priority: Lowest    
Version: 2.10.x   
Target Milestone: Untriaged   
Hardware: PC   
OS: Linux   
Tags: mono-community Is this bug a regression?: ---
Last known good build:
Attachments: Proposed fix
Proposed upgrade to the proposed fix for master

Description eb1 2012-01-16 12:08:24 UTC
A FlowLayoutPanel with AutoSize set to true and Docking to Top or Bottom doesn't resize properly if the child controls break to multiple lines. The size of the FlowLayoutPanel stays the same.
Comment 1 Miguel de Icaza [MSFT] 2012-01-16 14:52:07 UTC
Since we are not actively maintaining Windows.Forms, I have reset the Importance to Lowest.
Comment 2 eb1 2012-01-19 03:21:16 UTC
Created attachment 1228 [details]
Proposed fix
Comment 3 Miguel de Icaza [MSFT] 2012-01-19 22:24:07 UTC
Created attachment 1241 [details]
Proposed upgrade to the proposed fix for master

I had to manually apply this to master as it did not apply cleanly.

I could not get it to apply to mono-2-10 either.

I have attached the patch here for master.
Comment 4 eb1 2012-01-20 02:11:10 UTC
Thanks for upgrading the patch. Looks good to me.
Comment 5 eb1 2014-03-13 12:30:36 UTC
Proposed fix in PR #952.
Comment 6 Miguel de Icaza [MSFT] 2014-05-15 17:13:04 UTC
Applied