Bug 23206

Summary: MS allows threadpool threads to be renamed multiple times
Product: [Mono] Runtime Reporter: Rodrigo Kumpera <kumpera>
Component: GeneralAssignee: Alex Rønne Petersen <alexrp>
Status: VERIFIED FIXED    
Severity: normal CC: alexrp, atinc, mono-bugs+mono, mono-bugs+runtime, ramc, vargaz
Priority: Normal    
Version: unspecified   
Target Milestone: 4.6.0 (C8)   
Hardware: PC   
OS: Mac OS   
Tags: Is this bug a regression?: ---
Last known good build:

Description Rodrigo Kumpera 2014-09-19 18:16:14 UTC
Apparently threadpool threads can be renamed multiple times while non tp threads only once.

We should match this behavior as we got ppl relying on it.
Comment 1 Zoltan Varga 2014-09-22 17:08:00 UTC
Fixed in master.
Comment 2 Ram Chandra 2014-12-01 11:04:03 UTC
I have checked this issue with following builds and observed that I am still able to rename thread pool threads but the non thread pool thread I can set only once.

Mac OS X 10.10.0
Xamarin Studio: 5.7 (build 596)
Mono 3.12.0 ((detached/b75fa2b)
GTK+ 2.24.23 (Raleigh theme)
=== Build Information ===
Release ID: 507000596
Git revision: d996e9ba6874a0d64241e43e5e6b06322ce29c84
Build date: 2014-11-25 17:17:54-05
Xamarin addins: 8ca19707b41536a391f53364ee4ff9272711feb0

Screencast: http://www.screencast.com/t/nng1gFLqBEh

I am still getting the same behavior but I am unable to reopen this issue because the status of bug is non editable for me.
Comment 3 Zoltan Varga 2014-12-01 11:06:16 UTC
That is the correct behaviour.
Comment 5 Zoltan Varga 2014-12-01 11:53:59 UTC
-> REOPEN.
Comment 6 Alex Rønne Petersen 2016-04-08 04:39:13 UTC
I don't believe that this is true. I am not able to rename a TP thread more than once on MS.NET. So I've included a revert of this behavior in this PR: https://github.com/mono/mono/pull/2853
Comment 7 Alex Rønne Petersen 2016-08-30 04:55:24 UTC
The PR has been merged, so marking this as fixed.