Bug 20349

Summary: Crash (in iOS simulator) when instantiating a class with a static readonly reference to an empty struct
Product: iOS Reporter: mscoder610
Component: GeneralAssignee: Zoltan Varga <vargaz>
Status: RESOLVED FIXED    
Severity: normal CC: mono-bugs+monotouch, sadika, sebastien
Priority: Normal    
Version: 7.2.3   
Target Milestone: Untriaged   
Hardware: PC   
OS: Mac OS   
Tags: Is this bug a regression?: ---
Last known good build:
Attachments: Test Case for crash (Xamarin iOS project)
Full stack trace / crash details

Description mscoder610 2014-06-04 14:54:03 UTC
Using Xamarin.iOS 7.2.2.39 on a Mac, I'm running into a crash while running my app on the simulator. I was able to come up with a small test case (attached) - basically this:

[StructLayout(LayoutKind.Sequential)]
public struct MyStruct
{
}
public class MyClass
{
    public static readonly MyStruct StructInstance = new MyStruct();
}

Running a program that tries to create an instance of MyClass, using the Debug|iPhoneSimulator or Release|iPhoneSimulator configurations will crash with the following error:

* Assertion at ../../../../../mono/mono/mini/method-to-ir.c:10339, condition `addr' not met

The full stack trace is attached.
Adding a property to the struct causes the error go away, as does removing the explicit StructLayout(LayoutKind.Sequential) attribute.
The app runs fine on an actual iPad device (Release|iPhone configuration).

The error looks somewhat similar to Xamarin Bug 18963:
https://bugzilla.xamarin.com/show_bug.cgi?id=18963
Comment 1 mscoder610 2014-06-04 14:56:18 UTC
Created attachment 6980 [details]
Test Case for crash (Xamarin iOS project)
Comment 2 mscoder610 2014-06-04 14:56:42 UTC
Created attachment 6981 [details]
Full stack trace / crash details
Comment 3 Sadik Ali 2014-06-05 04:06:31 UTC
I have checked this issue and able to reproduce it.  I have created a new project and added the code from 'Appdelegate.cs' page given in comment 1 Attachment 'Test Case for crash (Xamarin iOS project)' in new created project. I added the breakpoint to debug this application and it crashed when it initiating a class with a static reference.

Screencast for same : http://screencast.com/t/FpVE2mwko

Supplement Info :
Build Log : https://gist.github.com/saurabh360/bf40403b3e68a5d0eae6
Application Output Log :  https://gist.github.com/saurabh360/cd66c30f4b1e6a6f71fe
IDE Log : https://gist.github.com/saurabh360/a94a851b947b2250df0f

Environment Info : 
=== Xamarin Studio ===

Version 5.0 (build 878)
Installation UUID: 1151d3d9-29c1-4339-b53c-a54856b47901
Runtime:
	Mono 3.4.0 ((no/c3fc3ba)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 304000204

=== Xamarin.Android ===

Version: 4.12.4 (Enterprise Edition)
Android SDK: /Users/shruti/Desktop/android-sdk-macosx
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		3.2   (API level 13)
		4.0   (API level 14)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.2   (API level 17)
		4.3   (API level 18)
		4.4   (API level 19)
Java SDK: /usr
java version "1.7.0_55"
Java(TM) SE Runtime Environment (build 1.7.0_55-b13)
Java HotSpot(TM) 64-Bit Server VM (build 24.55-b03, mixed mode)

=== Apple Developer Tools ===

Xcode 5.1 (5084)
Build 5B130a

=== Xamarin.iOS ===

Version: 7.2.3.39 (Enterprise Edition)
Hash: fc6f56b
Branch: 
Build date: 2014-05-19 19:10:29-0400

=== Xamarin.Mac ===

Xamarin.Mac: Not Installed

=== Build Information ===

Release ID: 500000878
Git revision: bcd66920d963483e7d638a2339c4022fe035b529
Build date: 2014-05-27 17:36:26-04
Xamarin addins: da9064ce55b0fa90930a7c437a4cc1ae0e5c778c

=== Operating System ===

Mac OS X 10.9.2
Darwin Shrutis-Mac-mini.local 13.1.0 Darwin Kernel Version 13.1.0
    Thu Jan 16 19:40:37 PST 2014
    root:xnu-2422.90.20~2/RELEASE_X86_64 x86_64
Comment 4 Sebastien Pouliot 2014-06-05 11:53:56 UTC
Looks like a JIT/runtime issue. Zoltan can you have a look ?
Comment 5 Zoltan Varga 2014-06-05 13:06:19 UTC
Fixed in mono master 2aa7af58636bc7c5499d4c150c64f51bf73b30c3.
Comment 6 mscoder610 2014-06-05 14:06:13 UTC
Very quick turnaround for this one, thanks.

Any idea what version of Xamarin.iOS the fix will make it into?