Bug 20244

Summary: isinf() check fails when compiling with CLANG
Product: [Mono] Runtime Reporter: Kyle Edwards <kyleedwardsny>
Component: packagingAssignee: Duncan Mak <duncan.mak>
Status: RESOLVED FIXED    
Severity: normal CC: mono-bugs+mono, mono-bugs+runtime, udhams, vargaz
Priority: ---    
Version: 3.2.x   
Target Milestone: ---   
Hardware: PC   
OS: Other   
Tags: Is this bug a regression?: ---
Last known good build:
Attachments: Patch to fix the isinf() test in configure.ac

Description Kyle Edwards 2014-05-31 23:35:02 UTC
When compiling with the CLANG compiler on FreeBSD 10, the configure.ac check for isinf() fails with the message "error: controlling expression type 'int' not compatible with any generic association type".

This is because the script checks using "isinf(1)", and CLANG does not automatically convert this to a float or double, and gets mad about it. Annoying, I know.

I have a patch I'm currently testing that changes this to "isinf(1.0)". I will post it if Mono successfully compiles on my machine.
Comment 1 Kyle Edwards 2014-06-01 12:24:22 UTC
Created attachment 6940 [details]
Patch to fix the isinf() test in configure.ac

Alright, I tested my patch and it made Mono compile successfully under CLANG on my FreeBSD 10 machine. I've attached the proposed patch.
Comment 2 Zoltan Varga 2014-06-03 10:08:09 UTC
Applied in 5d0df9e2c0be5b2376d96bc90dee4edd43152afe. Thanks.
Comment 4 Zoltan Varga 2014-08-05 15:16:51 UTC
This can be set to verified fixed.