Bug 19924

Summary: Step over AppDomain.Unload results into continued execution
Product: [Mono] Runtime Reporter: David Karlaš <david.karlas>
Component: DebuggerAssignee: Zoltan Varga <vargaz>
Status: RESOLVED FIXED    
Severity: normal CC: mono-bugs+mono, mono-bugs+runtime, tajinders
Priority: ---    
Version: unspecified   
Target Milestone: ---   
Hardware: PC   
OS: All   
Tags: Is this bug a regression?: ---
Last known good build:

Description David Karlaš 2014-05-20 07:59:30 UTC
using System;
class Program
{
 static void Main(string[] args)
 {
  AppDomain newDomain = AppDomain.CreateDomain("NewApplicationDomain");
  newDomain.ExecuteAssembly(@"/path/to/some/monoConsoleApp.exe");
  AppDomain.Unload(newDomain);//Breakpoint here and do StepOver(F10)
  Console.WriteLine ("This text is printed but debugger does not step on this line. Instead program execution is resumed and program finishes.");
 }
}
Comment 1 Zoltan Varga 2014-05-20 15:46:37 UTC
I can reproduce this. It looks like the breakpoint inserted by the single stepper is not hit.
Comment 2 Zoltan Varga 2014-05-29 15:08:56 UTC
Fixed by mono master 04619678389909f1ff6afc4aadb862029f246e23.
Comment 3 Tajinder Singh 2014-08-05 08:39:07 UTC
I have checked this issue with following builds and using attached code I am successfully able to step over and moves to next line. This is the screencast for the same: http://www.screencast.com/t/lbWVatcBOj

=== Xamarin Studio ===

Version 5.3 (build 412)
Installation UUID: 2591d519-875d-4afe-a3d9-5fcf391bbd2d
Runtime:
	Mono 3.8.0 ((no/9ffca33)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 308000002

=== Xamarin.Android ===

Version: 4.16.0 (Business Edition)
Android SDK: /Users/nischal/Desktop/android-sdk-macosx
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		3.2    (API level 13)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		4.5    (API level 21)
Java SDK: /usr
java version "1.6.0_35"
Java(TM) SE Runtime Environment (build 1.6.0_35-b10-428-11M3811)
Java HotSpot(TM) 64-Bit Server VM (build 20.10-b01-428, mixed mode)

=== Apple Developer Tools ===

Xcode 4.6.3 (2068)
Build 4H1503

=== Xamarin.iOS ===

Version: 7.2.6.28 (Business Edition)
Hash: 606f31a
Branch: 
Build date: 2014-08-01 15:27:48-0400

=== Xamarin.Mac ===

Version: 1.10.0.4 (Business Edition)

=== Build Information ===

Release ID: 503000412
Git revision: 77e042831804079a649ee83092ed36c7c10773a2
Build date: 2014-08-01 06:32:22-04
Xamarin addins: 57e379e6a9454a1c0d97aa3f770e7ae7cc16c522

=== Operating System ===

Mac OS X 10.7.4
Darwin nischals-Mac-mini.local 11.4.0 Darwin Kernel Version 11.4.0
    Mon Apr  9 19:32:15 PDT 2012
    root:xnu-1699.26.8~1/RELEASE_X86_64 x86_64