Bug 19887

Summary: Compilation of FParsec fails with error CS0159
Product: [Mono] Compilers Reporter: Andrea Canciani <ranma42>
Component: C#Assignee: Marek Safar <masafa>
Status: RESOLVED FIXED    
Severity: normal CC: mono-bugs+mono
Priority: ---    
Version: unspecified   
Target Milestone: ---   
Hardware: PC   
OS: Mac OS   
Tags: Is this bug a regression?: ---
Last known good build:
Attachments: Testcase for the issue

Description Andrea Canciani 2014-05-19 05:28:24 UTC
Created attachment 6834 [details]
Testcase for the issue

The compilation of FParsec (available here https://bitbucket.org/fparsec/main/get/tip.zip ) fails with:

../FParsecCS/Text.cs(389,17): error CS0159: The label `Switch:' could not be found within the scope of the goto statement
../FParsecCS/Text.cs(434,21): error CS0159: The label `Switch:' could not be found within the scope of the goto statement

This seems to be caused by some interaction between "switch" and the scope of labels.
A simplified testcase (that builds fine on VS2012 and on Mono C# compiler version 2.10.8.1) is attached.
Comment 1 Marek Safar 2014-05-27 04:48:15 UTC
Fixed in master
Comment 2 Andrea Canciani 2014-05-27 09:56:53 UTC
I confirm both that it fixes the testcase and that now FParsec can be built successfully with Mono.
Thanks! :)