Bug 18599

Summary: StringBuilder.AppendFormat stopped working in multithreading
Product: [Mono] Class Libraries Reporter: Sergey Zhukov <svg>
Component: mscorlibAssignee: Marek Safar <masafa>
Status: RESOLVED FIXED    
Severity: normal CC: craig, gacevedo, masafa, mono-bugs+mono, mono-bugs+runtime
Priority: ---    
Version: 3.2.x   
Target Milestone: Untriaged   
Hardware: PC   
OS: Linux   
Tags: Is this bug a regression?: ---
Last known good build:
Attachments: TestCase

Description Sergey Zhukov 2014-03-26 17:03:03 UTC
Created attachment 6415 [details]
TestCase

StringBuilder.AppendFormat/StringBuilder.ToString no more works in multithreading. Testcase is attached.


Mono JIT compiler version 4.0.0 ((no/b003229 Thu Mar 27 03:41:33 NOVT 2014)
Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
	TLS:           __thread
	SIGSEGV:       altstack
	Notifications: epoll
	Architecture:  x86
	Disabled:      none
	Misc:          softdebug 
	LLVM:          supported, not enabled.
	GC:            sgen

OS: Ubuntu Linux 12.04 32bit
Comment 1 Sergey Zhukov 2014-03-26 21:15:23 UTC
The bug was introduced in this commit eeeab3446fc26969d3ee639f2ca2ce670bffd71c
Comment 2 Marek Safar 2014-03-31 14:14:23 UTC
Fixed in master and mono 3.4
Comment 3 Craig Minihan 2014-05-30 08:26:18 UTC
This fix isn't in mono-3.4.0.tar.bz2 on http://download.mono-project.com/sources/mono/. It is only fixed in releases mono-3.4.0.202 and later on github.
Comment 4 Gabriel Acevedo 2014-07-29 23:51:59 UTC
*** Bug 21673 has been marked as a duplicate of this bug. ***