Bug 18235

Summary: System.Runtime.Caching.MemoryCache doesn't order expirable items correctly
Product: [Mono] Class Libraries Reporter: Craig Minihan <craig>
Component: System.WebAssignee: Bugzilla <bugzilla>
Status: RESOLVED FIXED    
Severity: normal CC: mono-bugs+mono
Priority: ---    
Version: master   
Target Milestone: Untriaged   
Hardware: PC   
OS: Linux   
Tags: Is this bug a regression?: ---
Last known good build:

Description Craig Minihan 2014-03-06 19:55:50 UTC
MemoryCache expired items are not expired in the correct order. This means items can live much longer than intended by the caller. 

The issue is hidden by Get() which does an expiry check and returns null so the item appears to be expired but is still in the timedItems heap.
Comment 1 Craig Minihan 2014-03-06 20:34:51 UTC
Fixed make in pull #937
Comment 2 Craig Minihan 2014-03-25 20:14:06 UTC
Merged into master in commit: e777f9d04576ff65198c34113ca165ec8463b348