Bug 17748

Summary: Support for continous integration using MSBuild
Product: Visual Studio Extensions Reporter: Mats Andreassen <mats.andreassen>
Component: Release ReadinessAssignee: Bugzilla <bugzilla>
Status: VERIFIED FIXED    
Severity: normal CC: akhileshk, arpitj, duncan.mak, grendel, mono-bugs+mtvs, narayanp, pj.beaman
Priority: Normal    
Version: 1.10.x   
Target Milestone: ---   
Hardware: PC   
OS: Windows   
Tags: Is this bug a regression?: ---
Last known good build:

Description Mats Andreassen 2014-02-13 09:37:48 UTC
Our company uses TeamCity for continous integration and release building. That means, we want ad-hoc IPA packages being built continously (or nightly) and AppStore IPA built when building for release.

I've been experimenting with MSBuild ( see my post at http://forums.xamarin.com/discussion/3688/how-to-build-ios-app ) but I have not reached my goals.

My suggestments for enhancement are two-fold:

1) Adding support for running the MSBuild target "_RemoteBuild" from the command line, using a dedicated OSX build server. Of course, the resulting IPA package should be available on the machine running the command line build.
2) The Visual Studio plugin should download any IPA packages built from VS to the machine running VS. Not all developers will have desktop or SSH access to their OSX build machine.
Comment 1 Dominique Louis 2014-02-13 10:22:30 UTC
Hi Mats,
  We are working on making this possible in a future release.


D.
Comment 2 Marek Habersack 2014-02-13 11:17:07 UTC
Hi Mats, 
 In addition to Dominique's comment, you can invoke VS IDE in the headless mode to build the application. Start VS command line prompt and issue the devenv /? command - it will show you the list of options you need to use the headless mode.
Comment 3 Arpit Jha 2015-07-14 02:00:27 UTC
I have checked this issue with XVS 3.11.666 and I am able to create iPA file from command line through msbuild . Here is the command:

C:\Users\Saurabh\Documents\Visual Studio 2013\Projects\App179>C:\Windows\Microso
ft.NET\Framework\v4.0.30319\MSBuild.exe /t:Build /p:Configuration=Debug;Platfor
m=iPhone App179.sln

Steps I have followed:
1.Connect VS to mac build host server.
2.Run above command in Command prompt.

If you are still getting the issue please let us know provide the environment info of VS (Windows machine) and XS( Mac machine).
Comment 4 Akhilesh kumar 2015-07-21 14:30:19 UTC
As per comment3, we are unable to reproduce this issue with XVS 3.11.666

So I am closing this issue.

Feel free to reopen it if anyone facing this issue.