Bug 5948

Summary: No color syntax for axml files in Designer/Source view in Visual Studio 2010
Product: Visual Studio Extensions Reporter: Chris Hardy [MSFT] <chrisntr>
Component: AndroidAssignee: Duncan Mak <duncan.mak>
Status: RESOLVED FIXED    
Severity: normal CC: gouri.kumari, jkolb, joe, josemiguel, kzu, mono-bugs+bugzilla, mono-bugs+monodroid, pj.beaman
Priority: ---    
Version: unspecified   
Target Milestone: ---   
Hardware: PC   
OS: Windows   
Tags: Is this bug a regression?: ---
Last known good build:

Description Chris Hardy [MSFT] 2012-07-02 13:36:00 UTC
This is due to this change here: https://bugzilla.xamarin.com/show_bug.cgi?id=5075 - wondered if a fix was planned?
Comment 1 Jose Miguel Torres 2012-08-04 12:20:56 UTC
Solved. There will be color syntax support in the next release.
Comment 2 Jeremy Kolb 2012-09-21 15:21:47 UTC
I don't see this in 4.2.6.
Comment 3 PJ 2012-10-17 13:59:32 UTC
Heyo Jose,

I just spent a little while trying to find the fix in any version of MFA. The first release after comment 1 was the 4.2.5 release.

I don't see the syntax highlighting in the .axml when creating a new Android project.

http://screencast.com/t/nLkfuVI1s6Xr


This behavior is the same in 4.2.7 and 4.2.8. Comment 2 seems to cover 4.2.6.



What was the commit that fixed this? Is it perhaps only in master?
Comment 7 PJ 2012-12-03 18:35:15 UTC
It looks like this commit is incompatible with feature requested in bug 5075. 

Aka the commit that fixes this causes bug 5075 to regress.

We should revert this patch before the release of MFA 4.4 to stable, or fix it.

This bug was never marked as RESOLVED FIXED - leaving as REOPENED.
Comment 8 GouriKumari 2013-05-21 12:02:22 UTC
The issue seems to be fixed:

http://screencast.com/t/aOGQXEgogLvj

Test Env:

VS2010
Xamarin.Android: 4.6.0049 (0e0e51f9)
Comment 9 GouriKumari 2013-05-21 12:17:02 UTC
Update to the the above comment :

Test Env:
VS 2010
Xamarin.Android : 4.6.0600 (6d7480e9)