Bug 58099

Summary: Unable to deploy app that uses SOAP web reference: sgen.exe exited with code -1
Product: [Mono] Runtime Reporter: tim.ahrentlov
Component: GeneralAssignee: Bugzilla <bugzilla>
Status: RESOLVED DUPLICATE    
Severity: normal CC: ludovic, mono-bugs+mono, mono-bugs+runtime
Priority: ---    
Version: 5.0 (2017-02)   
Target Milestone: ---   
Hardware: Macintosh   
OS: Mac OS   
Tags: Is this bug a regression?: ---
Last known good build:

Description tim.ahrentlov 2017-07-12 08:19:06 UTC
We have an App that uses SOAP. 

After upgrading tools to Mono 5.X we're unable to deploy because we're getting "sgen.exe" exited with code -1" when trying to compile. 

So right now we have to use an older Xamarin Studio tool-chain to deploy builds.

Please see the following links:

https://forums.xamarin.com/discussion/96856/error-msb6006-sgen-exe-exited-with-code-1-since-stable-update-last-tuesday
https://forums.xamarin.com/discussion/93991/unable-to-generate-a-temporary-class-in-release-mode
https://bugzilla.xamarin.com/show_bug.cgi?id=55697 (Private, I'm unable to access)
Comment 1 Ludovic Henry 2017-07-12 16:48:20 UTC

*** This bug has been marked as a duplicate of bug 55697 ***