Bug 57826

Summary: [mtouch] Symbol present in both assemblies using dlsym and assemblies not using dlsym
Product: iOS Reporter: Rolf Bjarne Kvinge [MSFT] <rolf>
Component: ToolsAssignee: Rolf Bjarne Kvinge [MSFT] <rolf>
Status: RESOLVED FIXED    
Severity: normal CC: mono-bugs+monotouch, sebastien
Priority: ---    
Version: XI 10.12 (d15-3)   
Target Milestone: 15.4   
Hardware: PC   
OS: Mac OS   
Tags: Is this bug a regression?: Yes
Last known good build: 15.2

Description Rolf Bjarne Kvinge [MSFT] 2017-06-28 10:53:41 UTC
[This is a spin-off from bug #57811]

The xamarin_start_wwan symbol is used in a P/Invoke in both Xamarin.iOS.dll and System.dll.

Xamarin.iOS.dll uses dlsym to call P/Invokes, while System.dll does not.

This confuses mtouch, and mtouch does not preserve the symbol when the executable is stripped, which prevents Xamarin.iOS.dll from calling the native function (System.dll still can though).
Comment 1 Rolf Bjarne Kvinge [MSFT] 2017-06-28 12:33:35 UTC
master: https://github.com/xamarin/xamarin-macios/pull/2260
Comment 2 Rolf Bjarne Kvinge [MSFT] 2017-06-28 12:34:53 UTC
There's a fairly trivial workaround: pass "--nosymbolstrip:<symbol>" as an additional mtouch argument.
Comment 3 Rolf Bjarne Kvinge [MSFT] 2017-06-28 12:36:23 UTC
@Sebastien, this is a regression in 15.3, but since I believe this to be somewhat obscure, and in any case there's a trivial workaround (comment #2), I don't think we need to get this in 15.3. Does that sound good?
Comment 4 Sebastien Pouliot 2017-06-28 12:47:50 UTC
@rolf yes

Did this happen in 15.3 or earlier ? Please file the last known bold field with the data. Thanks!
Comment 5 Rolf Bjarne Kvinge [MSFT] 2017-06-28 14:33:10 UTC
This regressed here: https://github.com/xamarin/xamarin-macios/commit/d17cb6556a4cb4ae9fec59e5687518f4ac3dc460, which is include in 15.3 (but not 15.2).
Comment 6 Rolf Bjarne Kvinge [MSFT] 2017-06-28 14:33:45 UTC
Fixed (master): https://github.com/xamarin/xamarin-macios/commit/2fa55d410d6cf09fed7751069a2704881ba270b1