Bug 56945

Summary: macOS: Button's text alignment does not work when setting colors.
Product: Forms Reporter: Brad Chase <xsirxx>
Component: FormsAssignee: Rui Marinho <rui.marinho>
Status: RESOLVED FIXED    
Severity: normal CC: jas, paul.dipietro
Priority: ---    
Version: unspecified   
Target Milestone: ---   
Hardware: PC   
OS: Windows   
Tags: Is this bug a regression?: ---
Last known good build:

Description Brad Chase 2017-05-29 18:56:12 UTC
The issue is when using attributed titles the layout uses NSMutableAttributedString instead of the default control alignment.

I have a fix I will put up shortly.  I am putting one up for the Button but this should affect LabelRenderer and other areas where attributed titles are used.  There might be other issues as well as not just horizontal layouts...
Comment 1 Brad Chase 2017-05-29 19:16:49 UTC
After looking through the rest of the code, it appears only the SearchBarRenderer is using the AttributedTitle at line 143, SearchBarRenderer.cs.

So there might not be any other controls with issues.  That does leave some questions about what else is being set but not used for the button.
Comment 2 Brad Chase 2017-05-29 19:24:28 UTC
Linkback to the PR for discussion

https://github.com/xamarin/Xamarin.Forms/pull/942
Comment 3 Rui Marinho 2017-05-30 09:37:48 UTC
Should be fixes on 2.3.6-pre1