Bug 55607

Summary: [iOS] Opening a ListView Cell's context action will disable context actions for all other ListViews
Product: Forms Reporter: Matthias <bruz>
Component: iOSAssignee: Chris King <chris.king>
Status: RESOLVED DUPLICATE    
Severity: normal CC: bruz, chris.king, jas, jimmy.garrido
Priority: ---    
Version: 2.3.4   
Target Milestone: ---   
Hardware: PC   
OS: Windows   
Tags: Is this bug a regression?: ---
Last known good build:
Attachments: sample solution

Description Matthias 2017-04-26 07:08:20 UTC
Created attachment 21782 [details]
sample solution

# Overview

When a Cell's context menu is opened (via swipe), opening another context menu is blocked, which is the wanted behavior. But when opening a Cell's context menu and navigating away, the menu stays open and blocks all ListViews from opening context actions. Even when the page with the ListView gets popped, it is even worse, because there is no chance to navigate back and close the menu, leaving the App in this state until forcibly killed by the user.



# Steps to reproduce

Start the sample iOS app.
Open a context menu in the list, then navigate to another tab, try opening context menus there.



# Expected results

The context menus in the other tabs can be opened as well.



# Actual result

Won't happen.



# Builds

2.3.3.192: GOOD
2.3.4.224: BAD



# Additional info

This commit https://github.com/xamarin/Xamarin.Forms/commit/cc0eb5ba4326de96a52c0318a61b89c3bcb098e5 added the blocking of context actions via a static field. There needs to be some checking if it is the same ListView instance.
Comment 1 Jimmy [MSFT] 2017-04-26 15:11:20 UTC

*** This bug has been marked as a duplicate of bug 55588 ***