Bug 54462

Summary: IsEnabled inconsistent behavior between iOS and Android
Product: Forms Reporter: Chase Long <chaselfromal>
Component: AndroidAssignee: Bugzilla <bugzilla>
Status: RESOLVED DUPLICATE    
Severity: normal CC: jas, jimmy.garrido
Priority: ---    
Version: 2.3.3   
Target Milestone: ---   
Hardware: PC   
OS: Windows   
Tags: IsEnabled Is this bug a regression?: ---
Last known good build:
Attachments: Solution demonstrating the problems

Description Chase Long 2017-04-04 17:04:03 UTC
Created attachment 21188 [details]
Solution demonstrating the problems

IsEnabled does not propagate recursively down the view hierarchy correctly on Android.

The attached sample solution includes the following view hierarchy:

ContentPage
  StackLayout
    Label
    Button
    Label

On iOS, setting IsEnabled on the ContentPage prevents clicking the nested button. On Android, setting IsEnabled on the ContentPage does not prevent clicking the nested button. In my opinion, the iOS behavior is correct, and the Android behavior is not correct.

Tested on Xamarin.Forms version 2.3.3.193, iPhone 7 Plus 10.3 simulator, Intel Atom (x86) Android 6.0 API level 23 emulator.
Comment 1 Chase Long 2017-04-04 17:09:43 UTC
At minimum, the documentation at https://developer.xamarin.com/api/property/Xamarin.Forms.VisualElement.IsEnabled/ should be updated to tell how IsEnabled behaves on each platform.
Comment 2 Jimmy [MSFT] 2017-04-04 20:39:52 UTC

*** This bug has been marked as a duplicate of bug 44096 ***