Bug 47950

Summary: 2.3.3 Regression: XAML compilation fails with behavior property and StaticResource
Product: Forms Reporter: Tom Gilder <tom>
Component: FormsAssignee: Bugzilla <bugzilla>
Status: VERIFIED FIXED    
Severity: blocker CC: jas, parmendrak, rui.marinho, sahou, stephane.delcroix
Priority: ---    
Version: 2.3.3   
Target Milestone: ---   
Hardware: Macintosh   
OS: Mac OS   
Tags: Is this bug a regression?: ---
Last known good build:
Attachments: Testcase

Description Tom Gilder 2016-11-25 11:56:21 UTC
Using a behavior with a StaticResource, such as:

    local:TestBehavior.ColorTest="{StaticResource MyColor}"

Results in XAML compilation error:

    "No property, bindable property, or event found for 'ColorTest' (XamlCompilationBehaviours)":

This worked in 2.3.2, but fails in 2.3.3. 

Using a value works fine:

    local:TestBehavior.ColorTest="Red"
Comment 1 Tom Gilder 2016-11-25 11:59:52 UTC
Created attachment 18672 [details]
Testcase

This may be related to Bug 47703
Comment 2 Stephane Delcroix 2016-11-30 10:00:59 UTC
this is not related to #47703 (47703 is not a regression).

https://github.com/xamarin/Xamarin.Forms/pull/562
Comment 3 Samantha Houts [MSFT] 2016-12-02 00:42:27 UTC
Should be fixed in 2.3.3-SR1. Thank you!
Comment 4 Parmendra Kumar 2016-12-08 12:22:39 UTC
Samantha, I have checked this issue with 2.3.3.175 and with latest forms version I am not getting any XAML compilation error which is mentioned in bug description.

But I am getting different runtime exception so I have filed new issue for the same: https://bugzilla.xamarin.com/show_bug.cgi?id=49307

Please have a look.
Comment 5 Parmendra Kumar 2016-12-08 12:25:19 UTC
An update for comment #4, I am not getting filed issue with latest form version 2.3.3.175 so I have change bug status Verified Fixed.
Comment 6 Stephane Delcroix 2016-12-08 15:29:20 UTC
Tom, note that the issue is fixed, but the Xaml in the sample is invalid.

should be 

<Application.Resources>
    <ResourceDictionary>
        <Color x:Key="MyColor">#c2d1d3</Color>
    </ResourceDictionary>
</Application.Resources>

in XF, Resources properties are unassigned by default