Bug 44636

Summary: Getting operation load failed popup in Android designer
Product: Visual Studio Extensions Reporter: Ben Beckley <benjamin.beckley>
Component: Android DesignerAssignee: Jérémie Laval <jeremie.laval>
Status: RESOLVED NOT_REPRODUCIBLE    
Severity: minor CC: alan, jeremie.laval, joe, john.miller, kzu, mono-bugs+bugzilla
Priority: ---    
Version: 4.2.0 (C8)   
Target Milestone: ---   
Hardware: PC   
OS: Windows   
Tags: Is this bug a regression?: ---
Last known good build:

Description Ben Beckley 2016-09-22 19:30:40 UTC
While verifying Bug 44460, I ran into a non-fatal error where I would sometimes get a popup stating
>The operation Load failed due to an internal error: android/support/v7/widget/ViewInfoStore$InfoRecord.
http://www.screencast.com/t/2qaVD9j9

Here is the accompanying error from the IDE log
https://gist.github.com/BenBeckley/345018a403597edf0cc4899d14817f91

Reproduction Steps (not 100% consistent):
1) Open the axml files in this project
https://github.com/jamesmontemagno/app-imagesearch-cogs
2) Rebuild the project
3) Open and close the axml files
4) Repeat steps 2 & 3 until the popup occurs

Env info: https://gist.github.com/BenBeckley/84a13ed3bc86353116b7821b3bc22800
Comment 1 Luis Aguilera 2017-02-18 00:21:38 UTC
C9 is now closed. We'll move this bug to the next scheduled milestone, "15.1". We'll continue working on these issues, and will attempt to resolve them ASAP.
Comment 2 John Miller [MSFT] 2017-07-07 16:11:11 UTC
I can confirm I am no longer able to reproduce this issue using the latest Visual Studio 15.3 preview builds. Marking this report as RESOLVED.