Bug 42847

Summary: UWP App Crashes When Resizing Window and Current Page Has a Map
Product: Forms Reporter: Jimmy [MSFT] <jimmy.garrido>
Component: WindowsAssignee: Bugzilla <bugzilla>
Status: RESOLVED DUPLICATE    
Severity: normal CC: FieldstrikeMobile, jas, kuramochia, sahou, wayne.creasey
Priority: ---    
Version: 2.3.0   
Target Milestone: ---   
Hardware: PC   
OS: Mac OS   
Tags: Is this bug a regression?: ---
Last known good build:
Attachments: repro project

Description Jimmy [MSFT] 2016-07-27 18:13:33 UTC
Created attachment 16801 [details]
repro project

### Overview
Trying to resize a UWP app window when the current page contains a map will cause the app to crash with:

> Exception thrown at 0x76FDDAE8 (KernelBase.dll) in ItronMasterDetail.UWP.exe: 0x40080201: WinRT originate error (parameters: 0x8000FFFF, 0x00000016, 0x0603ECC0).
> System.Exception: Catastrophic failure (Exception from HRESULT: 0x8000FFFF (E_UNEXPECTED))The thread 0x1bc has exited with code 0 (0x0).
> STATUS_STACK_BUFFER_OVERRUN encountered

This seems to happen when the map page is inside a NavigationPage but not when it's the root page. It also does not happen is the map page is pushed modally.

I was able to get some sort of stack trace which seems to point to the crash coming from the native Windows assemblies, so I'm not 100% sure that this is a bug with Forms: https://gist.github.com/jimmgarrido/f394aa6f4bb94e9ad0610382736d2076

I found a SO post with a similar "Catastrophic failure" error from the MapControl in a native UWP app that mentions the issue was fixed by an update to Windows: http://stackoverflow.com/a/33582281/6457998

If I run the same attached repro project on a machine running the upcoming Windows 10 version 1607 update, the app _does not_ crash.


### Steps to Reproduce
1. Run the attached repro project on Windows 10
2. Click "GotoMap"
3. Resize the window


### Expected Results
The window will resize.


### Actual Results
The app will crash.


### Testing Info
Tested with Forms and Forms.Maps 2.3.0.107.


### Workaround
Push the map page modally instead.
Comment 2 FieldstrikeMobile 2016-07-28 08:43:24 UTC
I am also seeing this bug
Comment 3 Samantha Houts [MSFT] 2016-07-28 17:20:36 UTC

*** This bug has been marked as a duplicate of bug 41900 ***