Bug 33809

Summary: Exception with SignalR 2.2 and Mono 4.2.0
Product: [Mono] Class Libraries Reporter: brian leung <brian>
Component: SystemAssignee: marcos.henrich
Severity: normal CC: hellspire, knocte, kumpera, marcus, mono-bugs+mono
Priority: ---    
Version: 4.2.0 (C6)   
Target Milestone: Untriaged   
Hardware: Other   
OS: Linux   
Tags: Is this bug a regression?: ---
Last known good build:

Description brian leung 2015-09-08 23:56:29 UTC
SignalR 2.x uses OWIN and requires the implementation of the method System.Web.HttpApplication.RegisterModule(), which is already done in Mono 4.2.0.

However, there is another exception when I tried to run the SignalR 2.x Tutorial project with Mono 4.2.0.  Details:

This is the SignalR 2.x tutorial project I used:

Thank you.
Comment 1 Rodrigo Kumpera 2015-09-09 15:59:34 UTC
Hey Marcos,

Could look into this one?
Comment 2 brian leung 2015-12-24 09:33:02 UTC
I just tried the new 4.2.1, the still got the same problem.

Please Help.

Thank You.
Comment 3 Adam Chu 2016-01-06 23:24:18 UTC
I'm experiencing the same issue. Anyone know whether this will be an easy fix or whether I should switch to an older version of SignalR?

Thanks everyone.
Comment 4 marcus 2016-01-11 07:17:21 UTC
I try to run the Microsoft simplest SignalR example. I have same issue too. Are there any hotfix ?
Comment 5 marcos.henrich 2016-01-27 11:09:30 UTC
Hi Brian,

Sorry for the delay.

I looked at the tutorial and your mono420_signalR2 repo.

Are you building the solution on visual studio and running it on linux with mono?

All sorts of problems can occur when mono tries to run binaries compiled against .NET class libraries.

SignalR repo https://github.com/SignalR/SignalR seems to have a solution called Microsoft.AspNet.SignalR.Mono.sln that should build something suitable to ran with mono.
Comment 6 marcos.henrich 2016-01-27 11:29:47 UTC
So I opened the solution that is in the tutorial in Xamarin Studio, built it and then ran xsp4 and I am getting the same error when I open it on the browser.

I will have to look further into it.
Comment 7 marcos.henrich 2016-01-28 17:55:59 UTC
Below is a pull request that fixes the exception in Microsoft.Owin. 


I tried to run SignalRChat with the fix, the exception no longer occur but the script in signalr/hub never finishes loading.

If the new issue is another bug on System.Web it will need to be pin pointed by someone with a deeper knowledge of SignalR.
Comment 8 marcos.henrich 2016-01-29 09:43:52 UTC
Fixed in mono/master d56d04602506540487506d0ee9875a635090877c

Fixed in cycle 7 mono/mono-4.3.2-branch 98f0a7b39a8e7b74620bff1de2bf14ed42936810