Bug 32230

Summary: isPresentedChanged raises multiple times
Product: Forms Reporter: Cody Beyer (MSFT) <cody.beyer>
Component: AndroidAssignee: Rui Marinho <rui.marinho>
Status: VERIFIED FIXED    
Severity: normal CC: anubhav, chris.king, parmendrak, rui.marinho
Priority: Normal    
Version: 1.4.4   
Target Milestone: ---   
Hardware: PC   
OS: Mac OS   
Tags: ac Is this bug a regression?: ---
Last known good build:

Description Cody Beyer (MSFT) 2015-07-21 13:40:57 UTC
### Description

The following sample app has a simple MasterDetail Page, where the isPresentedChanged event is raised multiple times when clicking on the Master menu

### Sample

https://www.dropbox.com/s/i7y9u6mmrybhx09/sample.tar.gz?dl=0

### Steps to Reproduce

1. Download sample app
2. Deploy to Android emulator
3. Click the "Hamburger" menu

### Expected Results

App should print "Here we go" to the output window once (prints once when event is raised)

### Actual Results

"Here we go" is printed multiple times

### Version

=== Xamarin Studio ===

Version 5.9.5 (build 5)
Installation UUID: 14e9db9d-4a59-440f-8c5b-890f54ec8c58
Runtime:
	Mono 4.0.3 ((detached/429313d)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400030013

=== Apple Developer Tools ===

Xcode 7.0 (8163.8)
Build 7A152u

=== Xamarin.iOS ===

Version: 8.99.0.321 (Business Edition)
Hash: 8443c2c
Branch: master
Build date: 2015-06-28 23:54:48-0400

=== Xamarin.Android ===

Version: 5.1.5.2 (Business Edition)
Android SDK: /Users/codybeyer/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.4   (API level 19)
		5.0   (API level 21)
Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

=== Xamarin Android Player ===

Version: Unknown version
Location: /Applications/Xamarin Android Player.app

=== Xamarin.Mac ===

Version: 2.0.2.84 (Business Edition)

=== Build Information ===

Release ID: 509050005
Git revision: 8d5aa047f336e5129fff1b174a972021b087bd76
Build date: 2015-07-14 16:37:43-04
Xamarin addins: 3bc005cd1e150ae5f206c1cf76164f47f2f2b62c

=== Operating System ===

Mac OS X 10.10.4
Darwin Codys-Macintosh.router 14.4.0 Darwin Kernel Version 14.4.0
    Thu May 28 11:35:04 PDT 2015
    root:xnu-2782.30.5~1/RELEASE_X86_64 x86_64
Comment 1 Rui Marinho 2015-08-16 16:02:53 UTC
Should be fixed in 1.5.0-pre2
Comment 2 Rui Marinho 2015-08-21 19:00:30 UTC
Correction pushed to 1.5.1-pre1.
Comment 3 Rui Marinho 2015-09-29 06:29:13 UTC
*** Bug 34269 has been marked as a duplicate of this bug. ***
Comment 4 Parmendra Kumar 2015-10-09 11:31:19 UTC
I have checked this issue with Xamarin.Forms 1.5.1-pre1 and its working fine.


Hence closing this issue.