Bug 29680

Summary: [XamarinVS 3.11] Unhelpful error apparently from Test Cloud integration: "Not implemented (Exception from HRESULT: 0x80004001 (E_NOTIMPL))"
Product: Visual Studio Extensions Reporter: Brendan Zagaeski (Xamarin Team, assistant) <brendan.zagaeski>
Component: GeneralAssignee: Bugzilla <bugzilla>
Status: RESOLVED DUPLICATE    
Severity: normal CC: adrian.murphy, chrisntr, Ian.Ceicys, joe, kzu, me, miguel, mono-bugs+bugzilla, pj.beaman
Priority: ---    
Version: 3.11 (C5)   
Target Milestone: 3.11.1 (C5SR1)   
Hardware: PC   
OS: Windows   
Tags: Is this bug a regression?: ---
Last known good build:
Attachments: Log files

Description Brendan Zagaeski (Xamarin Team, assistant) 2015-05-03 00:10:47 UTC
Created attachment 11035 [details]
Log files

[XamarinVS 3.11] Unhelpful error apparently from Test Cloud integration: "Not implemented (Exception from HRESULT: 0x80004001 (E_NOTIMPL))"


This looks related to Bug 29220. It's a different error message, but otherwise the symptoms are similar, so perhaps both errors have the same underlying cause.

This error itself does not block building, deploying, or debugging, but it is misleading and will cause confusion if building, deploying, or debugging fail for other reasons.


Regression status: REGRESSION compared to 3.9.547. It is most likely a "new feature bug" in the new Test Cloud feature, but it also affects users who aren't using the Test Cloud feature at all.




## Steps to reproduce

1. Open a new or existing Android or iOS project in Visual Studio (tested on both VS 2013 Update 4 and VS 2015 RC).

2. Right-click the app project in the Solution Explorer and select "Unload Project"

3. Right-click the app project again just to open the context menu.




## Results

### "Error List" window

> Error	1	Not implemented (Exception from HRESULT: 0x80004001 (E_NOTIMPL))


### "Output -> Test Cloud" window

> ERROR: Not implemented (Exception from HRESULT: 0x80004001 (E_NOTIMPL))




## Version information

### Windows 8.1 64-bit, VMWare Fusion 6.0.6 (2684343)

Microsoft Visual Studio Professional 2013
Version 12.0.31101.00 Update 4
Microsoft .NET Framework
Version 4.6.00057

Xamarin   3.11.445.0 (5061f92)
Xamarin.Android   5.1.0.115 (d23da369e436488f38c8ab8fe8a9ae7d9ea5256b)
Xamarin.iOS   8.10.0.0 (7741cc495ab0baf04ff0405d0604bc27f0ecae2e)


### OS X 10.9.5, MacBook Air

Xamarin.iOS 8.10.0.267 (Business Edition)
Hash: 6481535
Branch: master
Build date: 2015-04-27 04:38:13-0400

Xcode 6.2 (6776), Build 6C131e

Mono 4.0.0 (detached/d136b79)
Comment 2 Brendan Zagaeski (Xamarin Team, assistant) 2015-05-03 00:13:37 UTC
## Partial workaround

Manually remove the "Xamarin.TestCloud" part of the XamarinVS extension.

For example, for VS 2013:

1. Delete the following two files:
> C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\IDE\Extensions\Xamarin\Xamarin\3.11.445.0\Xamarin.TestCloud.Integration.pkgdef
> C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\IDE\Extensions\Xamarin\Xamarin\3.11.445.0\Xamarin.TestCloud.Integration.dll


2. Run the following command in a `cmd.exe` command prompt (remove the > greater-than symbol from the beginning of the line):
> "C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\IDE\devenv.exe" /setup /nosetupvstemplates
Comment 3 PJ 2015-05-04 10:13:01 UTC

*** This bug has been marked as a duplicate of bug 29470 ***
Comment 4 me 2015-08-07 03:20:36 UTC
That's a pity that the bug 29470 is not visible (even to registered users) !
Comment 5 Brendan Zagaeski (Xamarin Team, assistant) 2015-08-07 10:42:19 UTC
The only mildly interesting additional information in Bug 29470 is from when the QA team checked the fix (back at the beginning of May):

> This issue is working fine with Cycle 5 – Service Release 1 (XVS 3.11.538)