Bug 29267

Summary: Android.Content.Res.Resources+NotFoundException: Resource ID #0xff303030
Product: Forms Reporter: buddylove_123
Component: AndroidAssignee: Rui Marinho <rui.marinho>
Status: VERIFIED FIXED    
Severity: minor CC: Anthony.Coqui, chris.king, eric.maupin, kent.boogaart, parmendrak, rezamk, rui.marinho, sergio.paganoni
Priority: Normal    
Version: 1.5.0   
Target Milestone: ---   
Hardware: PC   
OS: Windows   
Tags: AC Is this bug a regression?: ---
Last known good build:
Attachments: Test Android App you can also reproduce with Forms2Native Sample

Description buddylove_123 2015-04-21 04:34:51 UTC
I created an empty POL Xamarin Forms project and added the following in the App constructor

        var TabbedPages = new TabbedPage { Title = "Test App" };
        MainPage = new NavigationPage(TabbedPages);
Then in the LoadApplication(new App()); line I get the following exception

Android.Content.Res.Resources+NotFoundException: Resource ID #0xff303030

I've attached my test project, please run within Visual Studio and enable the check box 'thrown' for Exception 'Common Language Runtime Exceptions' in the Debug->Exceptions dialog.

Please note I also get the error when I do the following which means the issue is with the NavigationPage.

        MainPage = new NavigationPage(new ContentPage());
When I do the following, then it works.
MainPage = new ContentPage();

Also reproduced the error with the Forms2Native sample project.
Comment 1 buddylove_123 2015-04-21 04:38:38 UTC
Created attachment 10837 [details]
Test Android App you can also reproduce with Forms2Native Sample
Comment 2 buddylove_123 2015-04-21 04:41:59 UTC
*** Bug 29266 has been marked as a duplicate of this bug. ***
Comment 4 Chris King 2015-05-26 17:53:43 UTC
Thank you for taking the time to submit this issue. I've downloaded the test case, updated to the latest version of forms, enabled first chance exceptions, and launched the app on my LGE Nexus 5 and see no exception. If there is any other context you can provide so I could reproduce this issue please let me know and I'll try again.

Warm regards,
Xamarin Forms Team
Comment 5 Eric Maupin 2015-07-14 13:03:59 UTC
Shows up on Android 5.0
Comment 6 Anthony 2015-07-15 11:48:34 UTC
I am also getting this.

Using Xamarin Android Player running Nexus 4 Lollipop
Comment 7 Reza 2015-07-16 13:43:41 UTC
Ditto.  I get the same.  Makes it really difficult to debug anything.

@Chris, you will need exceptions thrown from the Debug > Exceptions window.
Comment 8 Kent 2015-09-17 22:43:56 UTC
I get this too. And note that first-chance exceptions are indistinguishable from second-chance exceptions with VS2015's new Exception Settings dialog. They're either on or off - no other choice as far as I'm aware. So this is super annoying for those of us who like to leave break-on-exception turned on.
Comment 9 Rui Marinho 2015-09-23 06:11:27 UTC
Should be fixed in 1.5.1-pre1
Comment 10 Parmendra Kumar 2015-10-07 13:16:12 UTC
I have checked this issue with Xamarin.Forms 1.5.1-pre1 and its working fine.

Hence closing this issue.