Bug 17820

Summary: Process.Start on managed exe only works when mono is in PATH
Product: [Mono] Runtime Reporter: Mikayla Hutchinson [MSFT] <mhutch>
Component: io-layerAssignee: Bugzilla <bugzilla>
Status: RESOLVED FIXED    
Severity: normal CC: martin.baulig, masafa, mono-bugs+mono, mono-bugs+runtime, vargaz
Priority: ---    
Version: unspecified   
Target Milestone: ---   
Hardware: PC   
OS: Mac OS   
Tags: Is this bug a regression?: ---
Last known good build:

Description Mikayla Hutchinson [MSFT] 2014-02-17 12:25:58 UTC
Process.Start on a managed exe only works when mono is in PATH, because the runtime tries to run the exe using "mono". It should instead compute an absolute path the Mono runtime and use that.

May be tricky to make it work with the case where Mono is used as a shared library.
Comment 1 Mikayla Hutchinson [MSFT] 2014-02-25 19:51:27 UTC
*** Bug 17831 has been marked as a duplicate of this bug. ***
Comment 2 Zoltan Varga 2014-03-04 22:07:01 UTC
Fixed for osx in 243899a5bd75ca79808e706f1e6d1dce96f159fc.
Comment 3 Zoltan Varga 2014-03-05 16:47:07 UTC
Implemented support for linux and hopefully other platforms as well.
Comment 4 Marek Safar 2014-03-17 04:17:05 UTC
*** Bug 18368 has been marked as a duplicate of this bug. ***
Comment 5 Mikayla Hutchinson [MSFT] 2014-03-19 02:48:35 UTC
*** Bug 18368 has been marked as a duplicate of this bug. ***