Bug 9875 - Layout files (axml) source code editing does not have intellisense
Summary: Layout files (axml) source code editing does not have intellisense
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Android Designer ()
Version: 3.1.x
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Jérémie Laval
: 10033 16146 ()
Depends on:
Reported: 2013-01-29 19:09 UTC by Andrew Way
Modified: 2016-02-08 22:01 UTC (History)
13 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Andrew Way 2013-01-29 19:09:24 UTC
When I open a layout file (double-click) and select "source" on the bottom.
I do not get any intellisense. 

When I open a layout file with source-code editor. (right-click and select source-code editor), I get intellisense.
Comment 1 Mikayla Hutchinson [MSFT] 2013-02-04 18:41:15 UTC
*** Bug 10033 has been marked as a duplicate of this bug. ***
Comment 2 Chris Hardy [MSFT] 2013-03-01 11:52:49 UTC
I get the same problem on Windows 8:

=== Xamarin Studio ===

Version 4.0 (build 2003)
Installation UUID: 7237b315-a47d-4b42-a369-ecc3909f2dca
	Microsoft .NET 4.0.30319.18033
	GTK 2.24.13
	GTK# (

=== Xamarin.Android ===

Version: 4.6.0 (Business Edition)
Android SDK: C:\Users\chrisntr\AppData\Local\Android\android-sdk
	Supported Android versions:
		2.1 (API level 7)
		2.2 (API level 8)
		2.3 (API level 10)
		3.1 (API level 12)
		3.2 (API level 13)
		4.0 (API level 14)
Java SDK: C:\Program Files (x86)\Java\jdk1.6.0_31

=== Build Information ===

Git revision: Release ID: 400002003
Build date: 2013-02-19 19:47:39Z
Xamarin addins: b7a7aff09b352c13ded8a27439fd6d2250361511

=== Operating System ===

Windows 6.2.9200.0 (64-bit)
Comment 3 Mikayla Hutchinson [MSFT] 2013-11-12 14:44:24 UTC
*** Bug 16146 has been marked as a duplicate of this bug. ***
Comment 4 Miha Valencic 2014-02-15 06:06:55 UTC
More than one year from this bug report, this is still an issue. The workaround posted in the forums is to open the file in source code editor. Right click in solution explorer view, Open with -> Source code editor.
Comment 5 Luis Henrique 2014-03-04 23:35:51 UTC
Is there any hope that this will be solved anytime soon?

Although it is not a Huge bug, it is really anoying. I believe most of the people are used to switch between design and source editor, in order to edit the UI Code(AXML) and then quickly see the result in the design mode.

Miha, the workaround is consistent but still annoying - need to close the file all the time just to make a few modifications.
Comment 6 Jerold Haas 2014-06-25 13:05:55 UTC
Windows 8, Xamarin Studio 5.1 (build 462)

Still the same issue. Having a source view in the Layout Editor with no intellisense support pretty much renders that feature moot.

Additionally, opening the layout file in Source Code Editor prevents opening the layout file in Layout Editor and document switching between the two document tabs to check progress. I wouldn't mind this bug if doing so were possible.
Comment 7 Nate Cook 2014-11-13 18:05:20 UTC
Comment 8 Nate Cook 2014-11-13 18:09:11 UTC
It may seem like a small thing, but the problem is that I cannot just type the name of the axml file in the search bar at the top right and hit enter to open it up. Instead I have to manually find it in the solution explorer and right click on it, which takes much longer. And of course I forget sometimes.
Comment 9 Mike Krüger 2015-08-10 06:34:26 UTC
I suspect that the addin does make it's own editor and doesn't add the designer as a subview. This breaks all infrastructure we've.

I suppose that this can't be fixed before 6.0 unless the designer is added as a subview instead.
Comment 10 Stephen Shaw 2016-02-08 22:01:12 UTC
This should be fixed.